summaryrefslogtreecommitdiff
path: root/app-editors/vim/vim-9.0.0099.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim/vim-9.0.0099.ebuild')
-rw-r--r--app-editors/vim/vim-9.0.0099.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-editors/vim/vim-9.0.0099.ebuild b/app-editors/vim/vim-9.0.0099.ebuild
index b3882ef81361..ac5d29c84a4c 100644
--- a/app-editors/vim/vim-9.0.0099.ebuild
+++ b/app-editors/vim/vim-9.0.0099.ebuild
@@ -247,6 +247,14 @@ src_configure() {
# keep prefix env contained within the EPREFIX
use prefix && myconf+=( --without-local-dir )
+ if tc-is-cross-compiler ; then
+ export vim_cv_getcwd_broken=no \
+ vim_cv_memmove_handles_overlap=yes \
+ vim_cv_stat_ignores_slash=yes \
+ vim_cv_terminfo=yes \
+ vim_cv_toupper_broken=no
+ fi
+
econf \
--with-modified-by=Gentoo-${PVR} \
"${myconf[@]}"