summaryrefslogtreecommitdiff
path: root/app-editors/vim-core/vim-core-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/vim-core/vim-core-9999.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index f141342833a8..7e80dc2f16f9 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -2,6 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
+# Please bump with app-editors/vim and app-editors/gvim
+
VIM_VERSION="8.2"
inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop xdg-utils
@@ -14,23 +17,22 @@ else
https://dev.gentoo.org/~zlogene/distfiles/app-editors/vim/vim-8.2.0360-gentoo-patches.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
fi
+S="${WORKDIR}"/vim-${PV}
DESCRIPTION="vim and gvim shared files"
HOMEPAGE="https://vim.sourceforge.io/ https://github.com/vim/vim"
-SLOT="0"
LICENSE="vim"
+SLOT="0"
IUSE="nls acl minimal"
-DEPEND="sys-devel/autoconf"
-# avoid icon file collision bug #673880
+BDEPEND="sys-devel/autoconf"
+# Avoid icon file collision, bug #673880
RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
-S=${WORKDIR}/vim-${PV}
-
pkg_setup() {
- # people with broken alphabets run into trouble. bug 82186.
+ # people with broken alphabets run into trouble. bug #82186.
unset LANG LC_ALL
export LC_COLLATE="C"
@@ -50,7 +52,7 @@ src_prepare() {
-e '1s|.*|#!'"${EPREFIX}"'/usr/bin/awk -f|' \
"${S}"/runtime/tools/mve.awk || die "sed failed"
- # See #77841. We remove this file after the tarball extraction.
+ # See bug #77841. We remove this file after the tarball extraction.
rm -v "${S}"/runtime/tools/vimspell.sh || die "rm failed"
# Read vimrc and gvimrc from /etc/vim
@@ -59,7 +61,7 @@ src_prepare() {
# Use exuberant ctags which installs as /usr/bin/exuberant-ctags.
# Hopefully this pattern won't break for a while at least.
- # This fixes bug 29398 (27 Sep 2003 agriffis)
+ # This fixes bug #29398 (27 Sep 2003 agriffis)
sed -i 's/\<ctags\("\| [-*.]\)/exuberant-&/g' \
"${S}"/runtime/doc/syntax.txt \
"${S}"/runtime/doc/tagsrch.txt \
@@ -69,7 +71,7 @@ src_prepare() {
# Don't be fooled by /usr/include/libc.h. When found, vim thinks
# this is NeXT, but it's actually just a file in dev-libs/9libs
- # This fixes bug 43885 (20 Mar 2004 agriffis)
+ # This fixes bug #43885 (20 Mar 2004 agriffis)
sed -i 's/ libc\.h / /' "${S}"/src/configure.ac || die 'sed failed'
# gcc on sparc32 has this, uhm, interesting problem with detecting EOF
@@ -100,16 +102,16 @@ src_prepare() {
src_configure() {
local myconf
- # Fix bug 37354: Disallow -funroll-all-loops on amd64
+ # Fix bug #37354: Disallow -funroll-all-loops on amd64
# Bug 57859 suggests that we want to do this for all archs
filter-flags -funroll-all-loops
- # Fix bug 76331: -O3 causes problems, use -O2 instead. We'll do this for
+ # Fix bug #76331: -O3 causes problems, use -O2 instead. We'll do this for
# everyone since previous flag filtering bugs have turned out to affect
# multiple archs...
replace-flags -O3 -O2
- # Fix bug 18245: Prevent "make" from the following chain:
+ # Fix bug #18245: Prevent "make" from the following chain:
# (1) Notice configure.ac is newer than auto/configure
# (2) Rebuild auto/configure
# (3) Notice auto/configure is newer than auto/config.mk
@@ -125,7 +127,7 @@ src_configure() {
# things are for ppc64, see bug 86433.
for file in /dev/pty/s* /dev/console /dev/hvc/* /dev/hvc*; do
if [[ -e "${file}" ]]; then
- addwrite $file
+ addwrite ${file}
fi
done