summaryrefslogtreecommitdiff
path: root/app-editors/ng/ng-1.5_beta1-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ng/ng-1.5_beta1-r3.ebuild')
-rw-r--r--app-editors/ng/ng-1.5_beta1-r3.ebuild40
1 files changed, 22 insertions, 18 deletions
diff --git a/app-editors/ng/ng-1.5_beta1-r3.ebuild b/app-editors/ng/ng-1.5_beta1-r3.ebuild
index 428dbda5a7d9..92a75d620f79 100644
--- a/app-editors/ng/ng-1.5_beta1-r3.ebuild
+++ b/app-editors/ng/ng-1.5_beta1-r3.ebuild
@@ -1,39 +1,43 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI="7"
-inherit autotools toolchain-funcs
+inherit autotools flag-o-matic toolchain-funcs
MY_P="${P/_beta/beta}"
DESCRIPTION="Emacs like micro editor Ng -- based on mg2a"
HOMEPAGE="http://tt.sakura.ne.jp/~amura/ng/"
-SRC_URI="http://tt.sakura.ne.jp/~amura/archives/ng/${MY_P}.tar.gz"
-S="${WORKDIR}/${MY_P}"
+SRC_URI="http://tt.sakura.ne.jp/~amura/archives/${PN}/${MY_P}.tar.gz"
LICENSE="Emacs"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-RDEPEND="
- sys-libs/ncurses:0=
- !dev-java/nailgun"
+RDEPEND="sys-libs/ncurses:0="
DEPEND="${RDEPEND}"
+S="${WORKDIR}/${MY_P}"
PATCHES=(
- "${FILESDIR}/${MY_P}-ncurses.patch"
- "${FILESDIR}/${MY_P}-configure.patch"
+ "${FILESDIR}"/${MY_P}-ncurses.patch
+ "${FILESDIR}"/${MY_P}-configure.patch
)
src_prepare() {
default
- sed -i -e "/NO_BACKUP/s/undef/define/" config.h || die "sed failed"
- pushd sys/unix > /dev/null || die
+ sed -i "/NO_BACKUP/s/undef/define/" config.h
+ cd sys/unix || die
+ mv configure.{in,ac} || die
eautoconf
- popd > /dev/null || die
+ cd - >/dev/null || die
cp sys/unix/configure . || die
+ # written in K&R C
+ append-flags \
+ -Wno-implicit-function-declaration \
+ -Wno-implicit-int \
+ -Wno-return-type
}
src_configure() {
@@ -45,20 +49,20 @@ src_compile() {
}
src_install() {
- dobin ng
- dodoc docs/* MANIFEST dot.ng
+ dobin ${PN}
+ dodoc docs/* MANIFEST dot.${PN}
- insinto /usr/share/ng
+ insinto /usr/share/${PN}
doins bin/*
insinto /etc/skel
- newins dot.ng .ng
+ newins {dot,}.${PN}
}
pkg_postinst() {
elog
elog "If you want to use user Config"
- elog "cp /etc/skel/.ng ~/.ng"
- elog "and edit your .ng configuration file."
+ elog "cp /etc/skel/.${PN} ~/.${PN}"
+ elog "and edit your .${PN} configuration file."
elog
}