summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-9999-cmake-darwin.patch')
-rw-r--r--app-editors/neovim/files/neovim-9999-cmake-darwin.patch4
1 files changed, 2 insertions, 2 deletions
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
index cdfb38c3fef4..cba966a4ebfa 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
@@ -1,9 +1,9 @@
--- a/src/nvim/CMakeLists.txt
+++ b/src/nvim/CMakeLists.txt
-@@ -440,10 +440,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${prop})
+@@ -394,10 +394,6 @@ foreach(gen_include ${prop})
list(APPEND gen_cflags "-I${gen_include}")
endforeach()
+ list(APPEND gen_cflags "-I${DEPS_PREFIX}/include")
-if(APPLE AND CMAKE_OSX_SYSROOT)
- list(APPEND gen_cflags "-isysroot")
- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")