summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch')
-rw-r--r--app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch11
1 files changed, 11 insertions, 0 deletions
diff --git a/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
new file mode 100644
index 000000000000..4703dee52613
--- /dev/null
+++ b/app-editors/neovim/files/neovim-0.4.4-cmake_lua_version.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -384,7 +384,7 @@
+ option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
+
+ if(PREFER_LUA)
+- find_package(Lua 5.1 REQUIRED)
++ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
+ set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
+ set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
+ # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.