summaryrefslogtreecommitdiff
path: root/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/kile/kile-2.9.93_p20221123-r1.ebuild')
-rw-r--r--app-editors/kile/kile-2.9.93_p20221123-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild b/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
index 4da14337a591..3c11cf77aae7 100644
--- a/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
+++ b/app-editors/kile/kile-2.9.93_p20221123-r1.ebuild
@@ -63,6 +63,14 @@ DOCS=( kile-remote-control.txt )
PATCHES=( "${FILESDIR}/${P}-cmake.patch" )
+src_prepare() {
+ if has_version "media-gfx/okularpart:5"; then
+ eapply "${FILESDIR}/${P}-okularpart.patch"
+ fi
+
+ ecm_src_prepare
+}
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package pdf Poppler)