summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ghostwriter')
-rw-r--r--app-editors/ghostwriter/Manifest1
-rw-r--r--app-editors/ghostwriter/files/ghostwriter-24.08.2-fix-segfault.patch175
2 files changed, 0 insertions, 176 deletions
diff --git a/app-editors/ghostwriter/Manifest b/app-editors/ghostwriter/Manifest
index f1042043bea1..05acecf929e8 100644
--- a/app-editors/ghostwriter/Manifest
+++ b/app-editors/ghostwriter/Manifest
@@ -1,4 +1,3 @@
-AUX ghostwriter-24.08.2-fix-segfault.patch 5449 BLAKE2B 3b32fd32811137dee4169074e8f1e39cc7217d55b2725b84277dc987b06e62c85985486cc2275845530f117bd11a5ec52a2e14593cc630f45bcc24c3032f11e2 SHA512 5dd50e158e0dfc6feabf0680ca4a62909abd751ebba351901e0a69f8a3be04d807242cbee3e6bc722ca21eb257c43fc07e048f58bc9fca1e94d4ec2b8f138d29
DIST ghostwriter-24.12.2.tar.xz 2709628 BLAKE2B e719417243253a0215db89a4bc8e5db2fdbda6a3fd426bcb7a8bb1b690bcc59409105d07a30f79c3c5b5b3fe5a3ba035c61925c4a68f0cf10371b15916ec790d SHA512 5bec0b521a067d7c46f5dbc8a93c7cd6fd7131ef93bde4d81915438ba8a5d8f8791410e13fc4c690891a203b8a0234285d8baf6d2bce6116040eeb7f2da6cf47
DIST ghostwriter-24.12.3.tar.xz 2710828 BLAKE2B 9a35cb43fb2be6ad01add358d0e65c95615772114dfa94abd47b5408c84dc7e275623f3f9ce50bcaf0351224997c28228aa53cbe191e589588d07015fb89ea52 SHA512 e9cee38c8e89c8bb8b6c7651092966bd93b25053706fd7576a6643352380ec9ef662aca2613673536571e24ede70f104a877bfe96f37812952d7ff5c4e1571c7
EBUILD ghostwriter-24.12.2.ebuild 892 BLAKE2B a9ff52610f07e3ddb6ebdfc9af94315253ea0bda58051e55d1fd6b2a1ad7683422b6045c2ed4bef615c2f11be683faa58a64004f5d2b7118a96d946c372a6b9a SHA512 3fd1981599d45d8f9eb7de4e191e21724eb404bffbaae5dc1d005f87914673909d45578665c23e7db5d88807959acde5f511919a2e995d5b15f65755373a265d
diff --git a/app-editors/ghostwriter/files/ghostwriter-24.08.2-fix-segfault.patch b/app-editors/ghostwriter/files/ghostwriter-24.08.2-fix-segfault.patch
deleted file mode 100644
index 5466e47a319e..000000000000
--- a/app-editors/ghostwriter/files/ghostwriter-24.08.2-fix-segfault.patch
+++ /dev/null
@@ -1,175 +0,0 @@
-From bfca43e551729b9518772fed6fba19bb5dbe6646 Mon Sep 17 00:00:00 2001
-From: Megan Conkle <megan.conkle@kdemail.net>
-Date: Sat, 12 Oct 2024 23:34:27 -0700
-Subject: [PATCH] Fix segmentation fault when .conf file is missing
-
-Whenever ghostwriter.conf is missing (or the last used exporter within
-is empty), the app will crash with a segmentation fault due to accessing
-an uninitialed pointer to the current HTML exporter in appsettings.cpp.
-This commit ensures that the pointer is initialized to null before being
-checked for whether obtaining an exporter was successful.
-BUG: 465799
-
-(cherry picked from commit f82070ac7916b36bb0bfd84a5c0e96cb084a6e28)
-Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
----
- CHANGELOG.md | 8 ++++++++
- src/preview/htmlpreview.cpp | 24 ++++++++++++------------
- src/settings/appsettings.cpp | 18 ++++++++++++------
- 3 files changed, 32 insertions(+), 18 deletions(-)
-
-diff --git a/CHANGELOG.md b/CHANGELOG.md
-index 6f34002f..89017211 100644
---- a/CHANGELOG.md
-+++ b/CHANGELOG.md
-@@ -7,6 +7,14 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
-
- ## [Unreleased]
-
-+## [24.08.3]
-+
-+### Fixed
-+
-+* Issue #465799: Segmentation fault no longer occurs when .conf file is missing on first launch.
-+
-+## [24.08.0]
-+
- ### Added
-
- * Added more icons to menu actions.
-diff --git a/src/preview/htmlpreview.cpp b/src/preview/htmlpreview.cpp
-index db89dd29..5a600769 100644
---- a/src/preview/htmlpreview.cpp
-+++ b/src/preview/htmlpreview.cpp
-@@ -1,5 +1,5 @@
--/*
-- * SPDX-FileCopyrightText: 2014-2023 Megan Conkle <megan.conkle@kdemail.net>
-+/*
-+ * SPDX-FileCopyrightText: 2014-2024 Megan Conkle <megan.conkle@kdemail.net>
- *
- * SPDX-License-Identifier: GPL-3.0-or-later
- */
-@@ -38,7 +38,7 @@ public:
- HtmlPreviewPrivate(HtmlPreview *q_ptr)
- : q_ptr(q_ptr)
- {
-- ;
-+ proxy = new PreviewProxy(q_ptr);
- }
-
- ~HtmlPreviewPrivate()
-@@ -51,7 +51,7 @@ public:
- MarkdownDocument *document;
- bool updateInProgress;
- bool updateAgain;
-- PreviewProxy proxy;
-+ PreviewProxy *proxy;
- QString baseUrl;
- QRegularExpression headingTagExp;
- Exporter *exporter;
-@@ -91,7 +91,7 @@ HtmlPreview::HtmlPreview
- d->updateInProgress = false;
- d->updateAgain = false;
- d->exporter = exporter;
-- d->proxy.setMathEnabled(d->exporter->supportsMath());
-+ d->proxy->setMathEnabled(d->exporter->supportsMath());
-
- d->baseUrl = "";
-
-@@ -153,7 +153,7 @@ HtmlPreview::HtmlPreview
- this->setZoomFactor((horizontalDpi / 96.0));
-
- QWebChannel *channel = new QWebChannel(this);
-- channel->registerObject(QStringLiteral("previewProxy"), &d->proxy);
-+ channel->registerObject(QStringLiteral("previewProxy"), d->proxy);
- this->page()->setWebChannel(channel);
-
- QFile wrapperHtmlFile(":/resources/preview.html");
-@@ -240,22 +240,22 @@ void HtmlPreview::setHtmlExporter(Exporter *exporter)
-
- d->exporter = exporter;
- d->setHtmlContent("");
-- d->proxy.setMathEnabled(d->exporter->supportsMath());
-+ d->proxy->setMathEnabled(d->exporter->supportsMath());
- updatePreview();
- }
-
- void HtmlPreview::setStyleSheet(const QString &css)
- {
- Q_D(HtmlPreview);
--
-- d->proxy.setStyleSheet(css);
-+
-+ d->proxy->setStyleSheet(css);
- }
-
- void HtmlPreview::setMathEnabled(bool enabled)
- {
- Q_D(HtmlPreview);
--
-- d->proxy.setMathEnabled(enabled);
-+
-+ d->proxy->setMathEnabled(enabled);
- }
-
- void HtmlPreviewPrivate::onHtmlReady()
-@@ -312,7 +312,7 @@ void HtmlPreview::closeEvent(QCloseEvent *event)
-
- void HtmlPreviewPrivate::setHtmlContent(const QString &html)
- {
-- this->proxy.setHtmlContent(html);
-+ this->proxy->setHtmlContent(html);
- }
-
- QString HtmlPreviewPrivate::exportToHtml
-diff --git a/src/settings/appsettings.cpp b/src/settings/appsettings.cpp
-index a76c25a5..7d51ac5d 100644
---- a/src/settings/appsettings.cpp
-+++ b/src/settings/appsettings.cpp
-@@ -65,6 +65,7 @@ public:
- static AppSettings *instance;
-
- AppSettingsPrivate()
-+ : currentHtmlExporter(nullptr)
- {
- ;
- }
-@@ -677,6 +678,7 @@ void AppSettings::setShowUnbreakableSpaceEnabled(bool enabled)
- d->showUnbreakableSpaceEnabled = enabled;
- emit showUnbreakableSpaceEnabledChanged(d->showUnbreakableSpaceEnabled);
- }
-+
- AppSettings::AppSettings()
- : d_ptr(new AppSettingsPrivate())
- {
-@@ -843,17 +845,21 @@ AppSettings::AppSettings()
-
- QString exporterName = appSettings.value(constants::GW_LAST_USED_EXPORTER_KEY).toString();
-
-+ d->currentHtmlExporter = nullptr;
-+
- if (!exporterName.isEmpty()) {
- d->currentHtmlExporter = ExporterFactory::instance()->exporterByName(exporterName);
-- }
-
-- if (d->currentHtmlExporter) {
-- auto lastExportOptions = appSettings.value(constants::GW_LAST_USED_EXPORTER_PARAMS_KEY).toString();
-+ if (d->currentHtmlExporter) {
-+ auto lastExportOptions = appSettings.value(constants::GW_LAST_USED_EXPORTER_PARAMS_KEY).toString();
-
-- if (!lastExportOptions.isEmpty()) {
-- d->currentHtmlExporter->setOptions(lastExportOptions);
-+ if (!lastExportOptions.isEmpty()) {
-+ d->currentHtmlExporter->setOptions(lastExportOptions);
-+ }
- }
-- } else {
-+ }
-+
-+ if (!d->currentHtmlExporter) {
- d->currentHtmlExporter = ExporterFactory::instance()->htmlExporters().first();
- }
- }
---
-GitLab
-