summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-29.0.90.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-29.0.90.ebuild')
-rw-r--r--app-editors/emacs/emacs-29.0.90.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-editors/emacs/emacs-29.0.90.ebuild b/app-editors/emacs/emacs-29.0.90.ebuild
index 1d73792abc64..4b9556db2893 100644
--- a/app-editors/emacs/emacs-29.0.90.ebuild
+++ b/app-editors/emacs/emacs-29.0.90.ebuild
@@ -214,6 +214,14 @@ src_configure() {
myconf+=" --with-sound=$(usex sound oss)"
fi
+ if use jit; then
+ use zlib || ewarn \
+ "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
+ myconf+=" --with-zlib"
+ else
+ myconf+=" $(use_with zlib)"
+ fi
+
# Emacs supports these window systems:
# X11, pure GTK (without X11), or Nextstep (Aqua/Cocoa).
# General GUI support is enabled by the "gui" USE flag, then
@@ -225,14 +233,6 @@ src_configure() {
# Athena (Lucid), or no toolkit. They are enabled (in order of
# preference) with the "gtk", "motif", "Xaw3d", and "athena" flags.
- if use jit; then
- use zlib || ewarn \
- "USE flag \"jit\" overrides \"-zlib\"; enabling zlib support."
- myconf+=" --with-zlib"
- else
- myconf+=" $(use_with zlib)"
- fi
-
if ! use gui; then
einfo "Configuring to build without window system support"
myconf+=" --without-x --without-pgtk --without-ns"