summaryrefslogtreecommitdiff
path: root/app-editors/emacs/emacs-28.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs/emacs-28.0.9999.ebuild')
-rw-r--r--app-editors/emacs/emacs-28.0.9999.ebuild69
1 files changed, 21 insertions, 48 deletions
diff --git a/app-editors/emacs/emacs-28.0.9999.ebuild b/app-editors/emacs/emacs-28.0.9999.ebuild
index 57cb4bc23cf8..af22d98f0305 100644
--- a/app-editors/emacs/emacs-28.0.9999.ebuild
+++ b/app-editors/emacs/emacs-28.0.9999.ebuild
@@ -40,7 +40,7 @@ DESCRIPTION="The extensible, customizable, self-documenting real-time display ed
HOMEPAGE="https://www.gnu.org/software/emacs/"
LICENSE="GPL-3+ FDL-1.3+ BSD HPND MIT W3C unicode PSF-2"
-IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gtk2 gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils motif png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
+IUSE="acl alsa aqua athena cairo dbus dynamic-loading games gconf gfile gif +gmp gpm gsettings gtk gui gzip-el harfbuzz imagemagick +inotify jpeg json kerberos lcms libxml2 livecd m17n-lib mailutils png selinux sound source ssl svg systemd +threads tiff toolkit-scroll-bars wide-int Xaw3d xft +xpm xwidgets zlib"
RESTRICT="test"
RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
@@ -94,34 +94,23 @@ RDEPEND="app-emacs/emacs-common-gentoo[games?,gui(-)?]
)
)
gtk? (
- gtk2? ( x11-libs/gtk+:2 )
- !gtk2? (
- x11-libs/gtk+:3
- xwidgets? (
- net-libs/webkit-gtk:4=
- x11-libs/libXcomposite
- )
+ x11-libs/gtk+:3
+ xwidgets? (
+ net-libs/webkit-gtk:4=
+ x11-libs/libXcomposite
)
)
!gtk? (
- motif? (
- >=x11-libs/motif-2.3:0
- x11-libs/libXpm
+ Xaw3d? (
+ x11-libs/libXaw3d
x11-libs/libXmu
x11-libs/libXt
)
- !motif? (
- Xaw3d? (
- x11-libs/libXaw3d
- x11-libs/libXmu
- x11-libs/libXt
- )
- !Xaw3d? ( athena? (
- x11-libs/libXaw
- x11-libs/libXmu
- x11-libs/libXt
- ) )
- )
+ !Xaw3d? ( athena? (
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libXt
+ ) )
)
) )"
@@ -222,28 +211,16 @@ src_configure() {
Your version of GTK+ will have problems with closing open
displays. This is no problem if you just use one display, but
if you use more than one and close one of them Emacs may crash.
- See <https://bugzilla.gnome.org/show_bug.cgi?id=85715>.
+ See <https://gitlab.gnome.org/GNOME/gtk/-/issues/221> and
+ <https://gitlab.gnome.org/GNOME/gtk/-/issues/2315>.
If you intend to use more than one display, then it is strongly
- recommended that you compile Emacs with the Athena/Lucid or the
- Motif toolkit instead.
+ recommended that you compile Emacs with the Athena/Lucid
+ toolkit instead.
EOF
- if use gtk2; then
- myconf+=" --with-x-toolkit=gtk2 --without-xwidgets"
- use xwidgets && ewarn \
- "USE flag \"xwidgets\" has no effect if \"gtk2\" is set."
- else
- myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
- fi
- for f in motif Xaw3d athena; do
- use ${f} && ewarn \
- "USE flag \"${f}\" has no effect if \"gtk\" is set."
- done
- elif use motif; then
- einfo "Configuring to build with Motif toolkit"
- myconf+=" --with-x-toolkit=motif"
+ myconf+=" --with-x-toolkit=gtk3 $(use_with xwidgets)"
for f in Xaw3d athena; do
use ${f} && ewarn \
- "USE flag \"${f}\" has no effect if \"motif\" is set."
+ "USE flag \"${f}\" has no effect if \"gtk\" is set."
done
elif use athena || use Xaw3d; then
einfo "Configuring to build with Athena/Lucid toolkit"
@@ -252,12 +229,8 @@ src_configure() {
einfo "Configuring to build with no toolkit"
myconf+=" --with-x-toolkit=no"
fi
- if ! use gtk; then
- use gtk2 && ewarn \
- "USE flag \"gtk2\" has no effect if \"gtk\" is not set."
- use xwidgets && ewarn \
- "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
- fi
+ ! use gtk && use xwidgets && ewarn \
+ "USE flag \"xwidgets\" has no effect if \"gtk\" is not set."
fi
if tc-is-cross-compiler; then
@@ -423,7 +396,7 @@ src_install() {
tc-is-cross-compiler && DOC_CONTENTS+="\\n\\nEmacs did not write
a portable dump file due to being cross-compiled.
To create this file at run time, execute the following command:
- \\n${EMACS_SUFFIX} --batch --eval='(dump-emacs-portable
+ \\n${EMACS_SUFFIX} --batch -Q --eval='(dump-emacs-portable
\"/usr/libexec/emacs/${FULL_VERSION}/${CHOST}/emacs.pdmp\")'"
readme.gentoo_create_doc
}