summaryrefslogtreecommitdiff
path: root/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild')
-rw-r--r--app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
index cb262d172dd2..dec6aa315d1d 100644
--- a/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
+++ b/app-editors/emacs-vcs/emacs-vcs-27.0.9999.ebuild
@@ -120,7 +120,6 @@ DEPEND="${RDEPEND}
BDEPEND="virtual/pkgconfig
gzip-el? ( app-arch/gzip )"
-# pax_kernel? ( sys-apps/attr )
if [[ ${PV##*.} = 9999 ]]; then
BDEPEND="${BDEPEND}
@@ -311,6 +310,15 @@ src_install () {
# remove COPYING file (except for etc/COPYING used by describe-copying)
rm "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp/COPYING
+ if use systemd; then
+ insinto /usr/lib/systemd/user
+ sed -e "/^##/d" \
+ -e "/^ExecStart/s,emacs,${EPREFIX}/usr/bin/${EMACS_SUFFIX}," \
+ -e "/^ExecStop/s,emacsclient,${EPREFIX}/usr/bin/&-${EMACS_SUFFIX}," \
+ etc/emacs.service | newins - ${EMACS_SUFFIX}.service
+ assert
+ fi
+
if use gzip-el; then
# compress .el files when a corresponding .elc exists
find "${ED}"/usr/share/emacs/${FULL_VERSION}/lisp -type f \