summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-20220417.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20220417.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20220417.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20220417.ebuild b/app-doc/eclass-manpages/eclass-manpages-20220417.ebuild
new file mode 100644
index 000000000000..bb4dc06b483d
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20220417.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+BDEPEND="app-arch/xz-utils
+ sys-apps/gawk
+ sys-apps/groff"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}