summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-20190908.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20190908.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20190908.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20190908.ebuild b/app-doc/eclass-manpages/eclass-manpages-20190908.ebuild
new file mode 100644
index 000000000000..3e6b3491f481
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20190908.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/eclass-manpages/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+DEPEND="app-arch/xz-utils
+ sys-apps/gawk"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX=/usr
+}