summaryrefslogtreecommitdiff
path: root/app-doc/cppman
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/cppman')
-rw-r--r--app-doc/cppman/Manifest3
-rw-r--r--app-doc/cppman/cppman-0.4.8.ebuild29
-rw-r--r--app-doc/cppman/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
new file mode 100644
index 000000000000..39930cd1ac30
--- /dev/null
+++ b/app-doc/cppman/Manifest
@@ -0,0 +1,3 @@
+DIST cppman-0.4.8.tar.gz 3185978 BLAKE2B 9f662874eb6b6540e02a2b371fa47e53e0893239fbfcc65421fa5c7c4bc5f88c4cfd2facf08deb13606f5cf7c895a1a07e119e1c15bbc98b95af5f8056c6a5e8 SHA512 f5b93774988dad592b31670d6c21718bd034e4e94858982e1756e8db89779d12001fd786ba629211b038b173b7b507382277a3db7fb35363dba28cd029e69a7d
+EBUILD cppman-0.4.8.ebuild 682 BLAKE2B 33256eb62816da41ba68f0966dab033a47381a36c14a3905c25dc1f9ad04287eaaff559f11efe7dd6251ae6ac0f22b3c15bb7fbc73c286af8a82b963ed7ae202 SHA512 98290555c2161d4a6a4f5cd81b03cfe666bbf1265f109597dafb74643554c8f4cf2f6064acf449293e5a10f68472c4863e4b3432e9f60f4305f677087c82291f
+MISC metadata.xml 247 BLAKE2B 8da6363de18a0eb4c29efee8c35de35970668cf0107b011b7e885c8d151b7cbd90709f000548025593f2ed5b4bc2d512de53c0285805fec978b363536ccf1ec4 SHA512 a788f5e022a740fafc174856c3fcda9b4c43908303427ecb48deb2198b5c01f1103bcf4965d950e3f981be4036173f9e968e431c49d3df96061f24cdc202edbc
diff --git a/app-doc/cppman/cppman-0.4.8.ebuild b/app-doc/cppman/cppman-0.4.8.ebuild
new file mode 100644
index 000000000000..ed07e1b95c54
--- /dev/null
+++ b/app-doc/cppman/cppman-0.4.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="sqlite,threads"
+
+DISTUTILS_SINGLE_IMPL=true
+
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+LICENSE="GPL-3"
+
+SLOT="0"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+"
+
+# `./setup install` already installs docs
+DOCS=()
diff --git a/app-doc/cppman/metadata.xml b/app-doc/cppman/metadata.xml
new file mode 100644
index 000000000000..427bd08b7959
--- /dev/null
+++ b/app-doc/cppman/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">aitjcize/cppman</remote-id>
+ </upstream>
+</pkgmetadata>