summaryrefslogtreecommitdiff
path: root/app-doc/cppman/cppman-0.5.6.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/cppman/cppman-0.5.6.ebuild')
-rw-r--r--app-doc/cppman/cppman-0.5.6.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-doc/cppman/cppman-0.5.6.ebuild b/app-doc/cppman/cppman-0.5.6.ebuild
index 9e88d7bf5257..63a0409772a7 100644
--- a/app-doc/cppman/cppman-0.5.6.ebuild
+++ b/app-doc/cppman/cppman-0.5.6.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL=yes
DISTUTILS_USE_PEP517=setuptools
@@ -16,6 +16,8 @@ SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86 ~x64-macos"
+PROPERTIES="test_network"
+RESTRICT="test"
RDEPEND="
sys-apps/groff
@@ -32,6 +34,10 @@ src_prepare() {
distutils-r1_src_prepare
}
+python_test() {
+ ${EPYTHON} test/test.py || die
+}
+
src_install() {
distutils-r1_src_install
doman misc/cppman.1