summaryrefslogtreecommitdiff
path: root/app-doc/casting-spels-emacs
diff options
context:
space:
mode:
Diffstat (limited to 'app-doc/casting-spels-emacs')
-rw-r--r--app-doc/casting-spels-emacs/Manifest4
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild38
-rw-r--r--app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch11
-rw-r--r--app-doc/casting-spels-emacs/metadata.xml18
4 files changed, 71 insertions, 0 deletions
diff --git a/app-doc/casting-spels-emacs/Manifest b/app-doc/casting-spels-emacs/Manifest
new file mode 100644
index 000000000000..2485389604ec
--- /dev/null
+++ b/app-doc/casting-spels-emacs/Manifest
@@ -0,0 +1,4 @@
+AUX casting-spels-emacs-19-require-cl.patch 392 BLAKE2B 030efca6d6dbd245abe77fa060c165e2d0f40909123e005af4afd79a97fe113654a077c1be5d28ccd2be1a7c5eb824a2afe73f5854258ecd55d06c13c75a0454 SHA512 8170ff7e8ec91a12bcb292aa75a03901f020b6d13fa5e14d20648e2e324c833d23622b098651573181a5161ebc424dbc74ca5a3191811332d758721b4e3159f6
+DIST casting-spels-emacs-v19.zip 1883707 BLAKE2B 3cacf4d9f2afbc4d421aac86d8826fc72b762b8db48f8c7efc9df6b38139f8384704f5edb802d74ec102248ff99f7b177d32290eb006f7b2e69eeb52509e39ff SHA512 349d326a4787b1f1f7dd0630012f938fc67f354f3cb8f18a8b501dff3c1f0e7f07decea528a55f38e1f83d222c917455102103732560a426f37fb183e27d24ab
+EBUILD casting-spels-emacs-19-r2.ebuild 1000 BLAKE2B 03ab4794ff027981bf01239ed1e5ed75a5f26887c93aec729b491359593cd44b5cbb1e280526c8e3ff52943c226e54e63b221e3867d8637f06c56dccb33f5ec2 SHA512 8ff515225d3a2e3b40dbbd70f71927d3c3cc799318f1f28ecba6f64c53e63c2b791a5b48127208a1b80212d37d6ddcd3a288f76a47dcccf0684eae8fd32a9074
+MISC metadata.xml 887 BLAKE2B ab7370b4699643a3a4a023fd102d4a4b591607bf58e04e281f0f630aa645e4fa24baf084611af2b872cf627aa2fd76ee9e65ad767c61dc13a03a0f3047ce8c79 SHA512 c4feab498610b1200a1b321d3739dc3bc7b3d225212015ff27f073b06c15637f530dbed6b0f529a6899c28e3dba6df0954adbce790880fd40030855902845242
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild
new file mode 100644
index 000000000000..5f9f23dd698d
--- /dev/null
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit elisp-common
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="http://www.lisperati.com/casting-spels-emacs/html/casting-spels-emacs-1.html
+ https://www.gnu.org/software/emacs/casting-spels-emacs/"
+SRC_URI="https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+RDEPEND="virtual/emacs"
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ sed -i 's/\r$//' *.txt html/*.html {lisp,test}/*.el || die
+ # needs cl extensions
+ eapply "${FILESDIR}/${P}-require-cl.patch"
+ eapply_user
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el
+ dodoc README.txt test/walk-through-commands.el
+ docinto html
+ dodoc html/*.html
+ docinto html/images
+ dodoc images/*.jpg images/*.png
+ dosym html/images /usr/share/doc/${PF}/images
+ dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+}
diff --git a/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
new file mode 100644
index 000000000000..d7743d29fbf6
--- /dev/null
+++ b/app-doc/casting-spels-emacs/files/casting-spels-emacs-19-require-cl.patch
@@ -0,0 +1,11 @@
+--- casting-spels-emacs-orig/lisp/wizard-adventure-emacs.el 2007-09-17 04:18:48.000000000 +0200
++++ casting-spels-emacs/lisp/wizard-adventure-emacs.el 2008-09-05 19:59:21.000000000 +0200
+@@ -27,6 +27,8 @@
+
+ ;;; Code in the comic not needed to play the game is commented out...
+
++(require 'cl)
++
+ (setq eval-expression-print-length nil)
+
+ (setq objects '(whiskey-bottle bucket frog chain))
diff --git a/app-doc/casting-spels-emacs/metadata.xml b/app-doc/casting-spels-emacs/metadata.xml
new file mode 100644
index 000000000000..ba89606f7acb
--- /dev/null
+++ b/app-doc/casting-spels-emacs/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>gnu-emacs@gentoo.org</email>
+ <name>Gentoo GNU Emacs project</name>
+</maintainer>
+<longdescription>
+ Ever wonder what makes Lisp so powerful? Now you can find out for yourself -
+ And you can do it right inside your GNU Emacs text editor! If you've spent
+ any time working with Emacs, you'll find out that in order to get the full
+ power out of this uber text editor, you'll want to learn a little about
+ programming in Emacs Lisp. Anyone who has ever learned to program in Lisp
+ will tell you it is very different from any other programming language.
+ It is different in lots of surprising ways - This comic book will let you
+ find out how Lisp's unique design makes it so powerful!
+</longdescription>
+</pkgmetadata>