summaryrefslogtreecommitdiff
path: root/app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild')
-rw-r--r--app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild b/app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild
new file mode 100644
index 000000000000..201df4b33f97
--- /dev/null
+++ b/app-dicts/aspell-ru/aspell-ru-0.99.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+ASPELL_LANG="Russian"
+ASPELL_VERSION=6
+
+inherit aspell-dict-r1
+
+# very strange filename not supported by the gentoo naming scheme
+MY_P="aspell6-ru-0.99f7-1"
+
+SRC_URI="mirror://gnu/aspell/dict/ru/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+
+ einfo "Setting default dictionary to ru-yeyo"
+ cp -v ru-yeyo.multi ru.multi || die
+}