summaryrefslogtreecommitdiff
path: root/app-crypt
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/Manifest.gzbin25259 -> 25269 bytes
-rw-r--r--app-crypt/acme/Manifest2
-rw-r--r--app-crypt/acme/acme-2.11.0.ebuild64
-rw-r--r--app-crypt/certbot/Manifest2
-rw-r--r--app-crypt/certbot/certbot-2.11.0.ebuild65
-rw-r--r--app-crypt/gnupg/Manifest3
-rw-r--r--app-crypt/gnupg/gnupg-2.5.1.ebuild197
-rw-r--r--app-crypt/tpm2-tools/Manifest2
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-5.6.1.ebuild2
9 files changed, 335 insertions, 2 deletions
diff --git a/app-crypt/Manifest.gz b/app-crypt/Manifest.gz
index dd4b31d41ac3..3ebc7b3285ec 100644
--- a/app-crypt/Manifest.gz
+++ b/app-crypt/Manifest.gz
Binary files differ
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 2d8b0efd26f9..9d626c8571da 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
+DIST certbot-2.11.0.gh.tar.gz 2322114 BLAKE2B d266483d1ffc9f9274df3d5e389ed961758e77e9455a7324132bb2bfe4896db663642a98ac7250d35fbbd60d6aef0d6d2a58f98ad17130958dcfcd61283c2479 SHA512 ba47fc98faaf47278c58e107356371c06039f70ad539d2ca1ac39462bb45c7a6c55ed525d8bd8b11cd35cf807f3423e19309022751a492ba19ded79cfbb6d7f4
EBUILD acme-2.10.0.ebuild 1531 BLAKE2B 15f0041fcccb610f9fc9b4ca24ebcf871b5577bdc82e266c7fb4efe929dc431bd4020ee903510399fea14972d0a20590ca3471d6ec7c5f02e6cd0e4c0e406372 SHA512 b63e983e64a5a65f5c5f19a579c57ee8269ae8840e3c2afd2c16b2d4bc57290425d49d7882de4b1afcf7a5bfaf51bdea524e4f93d127d13eb2452a38e3f65270
+EBUILD acme-2.11.0.ebuild 1535 BLAKE2B 33a51a7dac9b7af72bcedeec816cbe5142a948f2d86c1843020c356c020a9b835a38fea1b557148c9b1b3727753d391c31e13a5533553e0c030c6d5fb93c5ce9 SHA512 1d88d4a3814ee9204b57d2f2623bdf7afc29d9c3cceece965802cfb03361e30bab6f4e8cf66bb31b41e3353e63d0f4383c1e17ab1b4789aaa196e2367e647193
EBUILD acme-9999.ebuild 1535 BLAKE2B 33a51a7dac9b7af72bcedeec816cbe5142a948f2d86c1843020c356c020a9b835a38fea1b557148c9b1b3727753d391c31e13a5533553e0c030c6d5fb93c5ce9 SHA512 1d88d4a3814ee9204b57d2f2623bdf7afc29d9c3cceece965802cfb03361e30bab6f4e8cf66bb31b41e3353e63d0f4383c1e17ab1b4789aaa196e2367e647193
MISC metadata.xml 401 BLAKE2B 30a2ac1f03749a8e3bb98723c57f47ab6bcf7bfa58c2b6e21c309fae279feca0d3612df6c2a1dafaf27b4f0781c583a140322feac1a1cf2c13e50861cad129ea SHA512 d8e725b71ca81ce4ca6565ed58271b283c25394448f0f48f726f232122577c33d5b2d726e117419b2fae99f9dae29a8080bb9564eccbca13368c83988cf3da01
diff --git a/app-crypt/acme/acme-2.11.0.ebuild b/app-crypt/acme/acme-2.11.0.ebuild
new file mode 100644
index 000000000000..7cc340a48d80
--- /dev/null
+++ b/app-crypt/acme/acme-2.11.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://pypi.org/project/acme/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index e56e57c15d4c..52eebdc8d382 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
+DIST certbot-2.11.0.gh.tar.gz 2322114 BLAKE2B d266483d1ffc9f9274df3d5e389ed961758e77e9455a7324132bb2bfe4896db663642a98ac7250d35fbbd60d6aef0d6d2a58f98ad17130958dcfcd61283c2479 SHA512 ba47fc98faaf47278c58e107356371c06039f70ad539d2ca1ac39462bb45c7a6c55ed525d8bd8b11cd35cf807f3423e19309022751a492ba19ded79cfbb6d7f4
EBUILD certbot-2.10.0.ebuild 1528 BLAKE2B 545abbd95761600f13ec22cbcf996ca4b1a04a1fb08b0dadcefa9696a35a3765f009733c3a8b153e22d24df223cb778ac05684110188a7886ee3eed2498d472c SHA512 43c0107185d0e36b0630d5b69e77bc32d43c6dcfe254b5fb8d0f92ae105452f3ca4013a6f1a859a85e0e473855d898637eb1938e7fd67fe138eb29700c3cd839
+EBUILD certbot-2.11.0.ebuild 1532 BLAKE2B 0fa348ecdb0750887cfd220ae9d55e147771b8fc503f2c8ee5d1004066ed1d4a3dccd804088271e09005939483871012f879e327ded91a5657a0205b7079ec89 SHA512 52bc685c1ab676c4f4dd96d40b3ea990a90b67a6d3977eca3e8bc3c7448f841d3a943458245ab16f217acb8db23882139d7fe6b871b2781e62d447c65d2f8c58
EBUILD certbot-9999.ebuild 1532 BLAKE2B 0fa348ecdb0750887cfd220ae9d55e147771b8fc503f2c8ee5d1004066ed1d4a3dccd804088271e09005939483871012f879e327ded91a5657a0205b7079ec89 SHA512 52bc685c1ab676c4f4dd96d40b3ea990a90b67a6d3977eca3e8bc3c7448f841d3a943458245ab16f217acb8db23882139d7fe6b871b2781e62d447c65d2f8c58
MISC metadata.xml 404 BLAKE2B 81266457a8db353ea7c650478797e49ba61828d9cf0116a94fc62e5ee7a87272b25660f45741cf98843cfc2a5c286284b59f568ad8f4ad33d2bce60bc04549dc SHA512 d7b1e2417cba958f59b05cac02fee15e361fe9657f28d53d6308011767637d838dc09dd4ce21ba56d5174af0fa4cb6a7fee5771f780d7127d9de5a9e628172fd
diff --git a/app-crypt/certbot/certbot-2.11.0.ebuild b/app-crypt/certbot/certbot-2.11.0.ebuild
new file mode 100644
index 000000000000..7762dd3262d4
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.11.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://pypi.org/project/certbot/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}
diff --git a/app-crypt/gnupg/Manifest b/app-crypt/gnupg/Manifest
index 24077998a562..3c02f5954242 100644
--- a/app-crypt/gnupg/Manifest
+++ b/app-crypt/gnupg/Manifest
@@ -17,8 +17,11 @@ DIST gnupg-2.2.43.tar.bz2 7435426 BLAKE2B ddf5c89d317e6ce8d1a5348f0ef81ffa1c61c9
DIST gnupg-2.2.43.tar.bz2.sig 119 BLAKE2B 38fd3790f5065d67d6b5323ef7abbb79facf00e5b9daba98e5078302fc3887423173ba434c7eff1e64faecef88d87aab9c057c570d6e96e8d0808f07f32d8fa1 SHA512 47c5354869b1825e56fa4276826fcde1ee41c70aab9b411686cf2733f4d1df9c006049e49e066b22e475bd37b337f9ffc97f8bbca0c62c0f32296909464a0643
DIST gnupg-2.4.5.tar.bz2 7889060 BLAKE2B a8b80cd4dfbb377066efb5c9f1b6cdc6d0cd1b18358c962781b5c06de1545117b13038a4655ae627c36bfd2e5fee127692df8729d6b23e1b31051ab6d897b733 SHA512 4d54744f09399c5899144d0cb5fdc2756e45b058db41b9ea9df3be03e80b914509e16ef35aa0248e7561185b80f7a5f9fd6afcab8ccff75ff82ed555448a38ff
DIST gnupg-2.4.5.tar.bz2.sig 238 BLAKE2B b236e7d62f49c8385f4fb81389bf10715d9c0a0cb5c0b4c20fb6ff1465d05a3c3657061284db23af988a1ca16c9fa393af3ce5cbd27934501eb41a4f448fff0a SHA512 5a06970e499d1eb5213b142a8a182e46f5f21b7cb32785a9e5069378797c124e151ce74727382003820042d60fd7a2f909143f44aa9ef282605875e1cab04aef
+DIST gnupg-2.5.1.tar.bz2 8126739 BLAKE2B 46955d2eebe14395adc0fdf81e89a32f3f9baaabfe1eee78f256a1fab25ce6fdb96b873678cfeb5e4abf4894c7ab4908359ed04cc6571ff442dcc5325b3ccd66 SHA512 733a11ff24145e23dd7d34d954a70c25bf70ecb1d517b8e15cc34bf690786c9f7007e4e99cde573500ac012852e91b29568fed00491f8c8254b3fb63ca5777cd
+DIST gnupg-2.5.1.tar.bz2.sig 238 BLAKE2B cd024a63ecb82a12e92444cbff8dbc9bef6a4e436d59957aae77927cce0baf9e282e63df7a5159a521c7c8694a0dbe96d6537ad3ec5f779c7c0dea8d02b5e70d SHA512 8ffd5cc72a2907972bf1854e804f6c215ff66ba2d6e91952700f49b2b5ba8bab035d0f42efdb0d3c3166301cda6e716394928bdd9c0d0d1e1789a02c7aa1a926
EBUILD gnupg-2.2.42-r4.ebuild 5703 BLAKE2B e3b01ff2397a38d7062799195fc52c969d0ac117211eb385c13280211a5e0c7467fe158e1fcc958afda9745c0a9b9ef482d21d4d8809de14ebefddcd089fa6ba SHA512 80845654342a6f301d80e7c22e9efd8531fbdc3cb989c99421ccc2bdc532f79983b4d44088558cfbf2a941869f2bd83c587c262d141851be43b5e15e01ddb0d0
EBUILD gnupg-2.2.43-r1.ebuild 5573 BLAKE2B 2fb3e5977f4f1828ba87b88100622b84e6c48e892e97e49e65456bfe97d9a8b4f19d5c0b53804eaa8f5a2a8cae3a256478c3b509da77aefb0e9835af3871ba30 SHA512 c6e3532520d1945046e08cef686691ae3efc21e9b2e6a7bf3a7c8e0c24d69130fde03ff6c8336ecd92bb7018bcda5555dd0c9f4332efffcfca1200ae9c039936
EBUILD gnupg-2.4.5-r1.ebuild 5894 BLAKE2B a235df7b022acf9bc4d11fa566b7edf39f60dd865802685f5bf68e6df76913589691476a2d48a885816e8aecc2112de14508e44882e43dd3bbefdedd54385a14 SHA512 f621e0a6227862acdab31bb5902e235b8fd5c3e3908be747d5680957d0d55ad5b92ba6a7e2436d1902cd304a40a62fdca8236e67563624bce0b4d683c0364d9b
EBUILD gnupg-2.4.5-r2.ebuild 6127 BLAKE2B 49d54a7d1eb0d549525223bd31960386ba4068ba59d7890e5e9396a7f341c1d67b9a34288bcad04278d720613173d9904ffd86d64e11744f19b3dda618c4d5ca SHA512 040f1fd9f1013afb74eb6257d03faac11ad3c5a003e5b1c8010ae280b8c5ca9f5b3dca1d935acdeb36191728f7dde3f42a16e8537ee578240bf0792f285cfccc
+EBUILD gnupg-2.5.1.ebuild 6134 BLAKE2B 59eda7c70745867290e44b8ce5f8c21b1e93a175f6e8096c23a973fdff1aebc2531f0d51870dbdb3b3682a9fc26ef71e171df8a571c8570f2667ae1a2e262f4c SHA512 0b7646838717c57384639ae93b4885982287cc5d9b7e941d1116f9358660b6edd42bbbba37b3ee6c6a0e4a4780a8c53ed98d8a49dbf251e7327f766ddc7eb11d
MISC metadata.xml 1189 BLAKE2B dae783678abfe0bae095970d96d952f591a569debad411708d29a2f128c6a291b73a33ee0b3491a6a5ec44c11f56d33c1531022e0ef9eaad3326c9cd0f79e3fb SHA512 bc7d6a9ceda213c134d9afc527fe0b0c87a4886a171b7a1e1f662f3978fec5e71323bae4c9f3882e1d763d5738446f161265070a8e513a59fa62ef0f792e9fa5
diff --git a/app-crypt/gnupg/gnupg-2.5.1.ebuild b/app-crypt/gnupg/gnupg-2.5.1.ebuild
new file mode 100644
index 000000000000..382e366f6c0d
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-2.5.1.ebuild
@@ -0,0 +1,197 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Maintainers should:
+# 1. Join the "Gentoo" project at https://dev.gnupg.org/project/view/27/
+# 2. Subscribe to release tasks like https://dev.gnupg.org/T6159
+# (find the one for the current release then subscribe to it +
+# any subsequent ones linked within so you're covered for a while.)
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/gnupg.asc
+# in-source builds are not supported: https://dev.gnupg.org/T6313#166339
+inherit flag-o-matic out-of-source multiprocessing systemd toolchain-funcs verify-sig
+
+MY_P="${P/_/-}"
+
+DESCRIPTION="The GNU Privacy Guard, a GPL OpenPGP implementation"
+HOMEPAGE="https://gnupg.org/"
+SRC_URI="mirror://gnupg/gnupg/${MY_P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnupg/gnupg/${P}.tar.bz2.sig )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+"
+SLOT="0"
+#KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="bzip2 doc ldap nls readline selinux +smartcard ssl test +tofu tpm tools usb user-socket wks-server"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="test? ( tofu )"
+
+# Existence of executables is checked during configuration.
+# Note: On each bump, update dep bounds on each version from configure.ac!
+DEPEND="
+ >=dev-libs/libassuan-2.5.0:=
+ >=dev-libs/libgcrypt-1.9.1:=
+ >=dev-libs/libgpg-error-1.46
+ >=dev-libs/libksba-1.6.3
+ >=dev-libs/npth-1.2
+ >=net-misc/curl-7.10
+ sys-libs/zlib
+ bzip2? ( app-arch/bzip2 )
+ ldap? ( net-nds/openldap:= )
+ readline? ( sys-libs/readline:0= )
+ smartcard? ( usb? ( virtual/libusb:1 ) )
+ tofu? ( >=dev-db/sqlite-3.27 )
+ tpm? ( >=app-crypt/tpm2-tss-2.4.0:= )
+ ssl? ( >=net-libs/gnutls-3.2:0= )
+"
+RDEPEND="
+ ${DEPEND}
+ nls? ( virtual/libintl )
+ selinux? ( sec-policy/selinux-gpg )
+ wks-server? ( virtual/mta )
+"
+PDEPEND="
+ app-crypt/pinentry
+"
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( sys-apps/texinfo )
+ nls? ( sys-devel/gettext )
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+
+DOCS=(
+ ChangeLog NEWS README THANKS TODO VERSION
+ doc/FAQ doc/DETAILS doc/HACKING doc/TRANSLATE doc/OpenPGP doc/KEYSERVER
+)
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.20-gpgscm-Use-shorter-socket-path-lengts-to-improve-tes.patch
+ "${FILESDIR}"/${PN}-2.4.5-revert-rfc4880bis.patch # bug #926186
+)
+
+src_prepare() {
+ default
+
+ GNUPG_SYSTEMD_UNITS=(
+ dirmngr.service
+ dirmngr.socket
+ gpg-agent-browser.socket
+ gpg-agent-extra.socket
+ gpg-agent.service
+ gpg-agent.socket
+ gpg-agent-ssh.socket
+ )
+
+ cp "${GNUPG_SYSTEMD_UNITS[@]/#/${FILESDIR}/}" "${T}" || die
+
+ # Inject SSH_AUTH_SOCK into user's sessions after enabling gpg-agent-ssh.socket in systemctl --user mode,
+ # idea borrowed from libdbus, see
+ # https://gitlab.freedesktop.org/dbus/dbus/-/blob/master/bus/systemd-user/dbus.socket.in#L6
+ #
+ # This cannot be upstreamed, as it requires determining the exact prefix of 'systemctl',
+ # which in turn requires discovery in Autoconf, something that upstream deeply resents.
+ sed -e "/DirectoryMode=/a ExecStartPost=-${EPREFIX}/bin/systemctl --user set-environment SSH_AUTH_SOCK=%t/gnupg/S.gpg-agent.ssh" \
+ -i "${T}"/gpg-agent-ssh.socket || die
+
+ # definition of getpeername etc uses different things like socket_fd_t
+ [[ ${CHOST} == *-solaris* ]] &&
+ append-cflags $(test-flags-CC -Wno-incompatible-pointer-types)
+}
+
+my_src_configure() {
+ # Upstream don't support LTO, bug #854222.
+ filter-lto
+
+ local myconf=(
+ $(use_enable bzip2)
+ $(use_enable nls)
+ $(use_enable smartcard scdaemon)
+ $(use_enable ssl gnutls)
+ $(use_enable test all-tests)
+ $(use_enable test tests)
+ $(use_enable tofu)
+ $(use_enable tofu keyboxd)
+ $(use_enable tofu sqlite)
+ $(usex tpm '--with-tss=intel' '--disable-tpm2d')
+ $(use smartcard && use_enable usb ccid-driver || echo '--disable-ccid-driver')
+ $(use_enable wks-server wks-tools)
+ $(use_with ldap)
+ $(use_with readline)
+
+ # Hardcode mailprog to /usr/libexec/sendmail even if it does not exist.
+ # As of GnuPG 2.3, the mailprog substitution is used for the binary called
+ # by wks-client & wks-server; and if it's autodetected but not not exist at
+ # build time, then then 'gpg-wks-client --send' functionality will not
+ # work. This has an unwanted side-effect in stage3 builds: there was a
+ # [R]DEPEND on virtual/mta, which also brought in virtual/logger, bloating
+ # the build where the install guide previously make the user chose the
+ # logger & mta early in the install.
+ --with-mailprog=/usr/libexec/sendmail
+
+ --disable-ntbtls
+ --enable-gpgsm
+ --enable-large-secmem
+
+ CC_FOR_BUILD="$(tc-getBUILD_CC)"
+ GPGRT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpgrt-config"
+
+ $("${S}/configure" --help | grep -o -- '--without-.*-prefix')
+ )
+
+ if use prefix && use usb; then
+ # bug #649598
+ append-cppflags -I"${ESYSROOT}/usr/include/libusb-1.0"
+ fi
+
+ # bug #663142
+ if use user-socket; then
+ myconf+=( --enable-run-gnupg-user-socket )
+ fi
+
+ # glib fails and picks up clang's internal stdint.h causing weird errors
+ tc-is-clang && export gl_cv_absolute_stdint_h="${ESYSROOT}"/usr/include/stdint.h
+
+ econf "${myconf[@]}"
+}
+
+my_src_compile() {
+ default
+
+ use doc && emake -C doc html
+}
+
+my_src_test() {
+ export TESTFLAGS="--parallel=$(makeopts_jobs)"
+
+ default
+}
+
+my_src_install() {
+ emake DESTDIR="${D}" install
+
+ use tools && dobin tools/{gpgconf,gpgsplit,gpg-check-pattern} tools/make-dns-cert
+
+ dosym gpg /usr/bin/gpg2
+ dosym gpgv /usr/bin/gpgv2
+ echo ".so man1/gpg.1" > "${ED}"/usr/share/man/man1/gpg2.1 || die
+ echo ".so man1/gpgv.1" > "${ED}"/usr/share/man/man1/gpgv2.1 || die
+
+ dodir /etc/env.d
+ echo "CONFIG_PROTECT=/usr/share/gnupg/qualified.txt" >> "${ED}"/etc/env.d/30gnupg || die
+
+ use doc && dodoc doc/gnupg.html/*
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ use tools && dobin tools/{convert-from-106,mail-signed-keys,lspgpot}
+ use doc && dodoc doc/*.png
+
+ # Dropped upstream in https://git.gnupg.org/cgi-bin/gitweb.cgi?p=gnupg.git;a=commitdiff;h=eae28f1bd4a5632e8f8e85b7248d1c4d4a10a5ed.
+ dodoc "${FILESDIR}"/README-systemd
+ systemd_douserunit "${GNUPG_SYSTEMD_UNITS[@]/#/${T}/}"
+}
diff --git a/app-crypt/tpm2-tools/Manifest b/app-crypt/tpm2-tools/Manifest
index e16adc78795d..834464e8ccf4 100644
--- a/app-crypt/tpm2-tools/Manifest
+++ b/app-crypt/tpm2-tools/Manifest
@@ -9,6 +9,6 @@ DIST tpm2-tools-5.6.tar.gz 1266731 BLAKE2B fe88722c26d62128cd6dfbdd8ef2568656a75
DIST tpm2-tools-5.7.tar.gz 1339035 BLAKE2B 3984f25176e0b092793a33a0b40b396bc650de989e0b600989d11439cccdf7bc410535c01e1a0e985ab67b36b63eb02d392342aa1746b86727ba22d67d522389 SHA512 629b0b1826815877f452935285f7b3fe0f32bd24fe9130eb169a2dc9b7b254a737797043af9eea68be706b87c32ab2b7189151360c9c00bc5c31dce62a799670
EBUILD tpm2-tools-5.5.ebuild 1643 BLAKE2B 5029ad3299b8db9d0005866660db88884833619fade7131a6b4b7b42f1ce62a2fe8eb94ad175b889bd2d9c2b6d4bf5d91d2455bd0ea0a9ad8e0c59565c73b1e2 SHA512 195dc492373400638ec7baa5c191e7eeea646523f296ff16422ae56d7347e5e6fdea12d199e8d32bc700790f9a206b5e84b0e52348f67b4ad681e6889cf1703e
EBUILD tpm2-tools-5.6-r1.ebuild 2230 BLAKE2B 29bd871f43e77ad687efdaf30866929b0c78b7013e2fb3aec8ffe6aee30bb184efee7b96a3e0cd487bd4c6510494f7b8df91ddecfc43c53b711cdbc45f69271f SHA512 ddc4b86bf59291e6fdbb0b443435f135992d4e0ba9e7b69ab0a5efb0f950ed8004fa9a3155cbb1fc26c41b59241769d6c16e65180ae474b48b43ce8e27d20a9f
-EBUILD tpm2-tools-5.6.1.ebuild 2332 BLAKE2B fbac71379bcfa8bb432e9fc4024be27d3ce3cab7dea3dfa35e5c14c4b3989f9d268da7ac2141f2de5ca97a92d139b728530dc07a1bdd4cb7e1da6005cca10594 SHA512 3b3049891ee579ca0bc5ef630e5171259297411b317ccbee1e8ff5bb26420d4a48572b111003ad87c90220622686c57ebd832c9528ed77d24ea518e6c820d25d
+EBUILD tpm2-tools-5.6.1.ebuild 2331 BLAKE2B 780cc29ffa04e805e2504a8180a741959c162206e93b32cc5a70d8000b4ea494173ba0a37e9c18f7b2517b46c9fa46cd738709489a7bd524d55dfb1f53154c65 SHA512 7f5f35c6b7294b7f4f22487f8af1d2766b946573e8abbaaec6e040e82dceb60eb15155c8dcaa7f3a9f4b192b09ef49fa50ab3df7265d5e5e0b5276047f24b1bb
EBUILD tpm2-tools-5.7.ebuild 1946 BLAKE2B 036b526770caf7db787ba78f2646d1e9d52fa20998a36bb8412fdf308ea7a90e76c8abf2ad9bcb334f1385349d04ebf0eac619ca650612292ebb5ea5e7def2dc SHA512 3bd0836de7d949a59b2f134b7211f25292fc748db05b331a2488a44c6ae01cc3edcb2d57a077e7dcf6a9395bf057f26b56632e085a940a971c7c6df0d5a806f9
MISC metadata.xml 560 BLAKE2B fe8daaba2a7586247537f8ed7b92769676b20f2c1377f7bb582dff49e06cf3f9beba4f79e28f10ea76d67d089eb152b060b091414dd9b47c5694ca153211421f SHA512 a744fcc50c7e44b1939190150404aee9054eab8e921e6f63cafa58dc80be5f20692632509de85399b6a9633701da72fd951e8bcfbe9e5177f315fa1dcbcc9ee5
diff --git a/app-crypt/tpm2-tools/tpm2-tools-5.6.1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-5.6.1.ebuild
index f8ad3a1b74c9..d66c553ca767 100644
--- a/app-crypt/tpm2-tools/tpm2-tools-5.6.1.ebuild
+++ b/app-crypt/tpm2-tools/tpm2-tools-5.6.1.ebuild
@@ -13,7 +13,7 @@ SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/tpm2-tools-5.
LICENSE="BSD"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~ppc64 x86"
+KEYWORDS="amd64 arm arm64 ppc64 x86"
IUSE="+fapi test"
RESTRICT="!test? ( test )"