summaryrefslogtreecommitdiff
path: root/app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild')
-rw-r--r--app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild b/app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild
new file mode 100644
index 000000000000..c1c671051c91
--- /dev/null
+++ b/app-crypt/yubikey-manager/yubikey-manager-4.0.8-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1
+
+DESCRIPTION="Python library and command line tool for configuring a YubiKey"
+HOMEPAGE="https://developers.yubico.com/yubikey-manager/"
+# Per https://github.com/Yubico/yubikey-manager/issues/217, Yubico is
+# the official source for tarballs, not Github
+SRC_URI="https://developers.yubico.com/${PN}/Releases/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+IUSE="ssl"
+
+# app-crypt/ccid required for
+# - 'ykman oath'
+# - 'ykman openpgp'
+# - 'ykman piv'
+RDEPEND="
+ app-crypt/ccid
+ dev-python/click[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/fido2:0/0.9[${PYTHON_USEDEP}]
+ dev-python/pyscard[${PYTHON_USEDEP}]
+ ssl? ( >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}] )"
+BDEPEND="test? (
+ dev-python/makefun[${PYTHON_USEDEP}]
+)"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+ doman man/ykman.1
+}