summaryrefslogtreecommitdiff
path: root/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild')
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild
new file mode 100644
index 000000000000..6b5facd3a1c1
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
+
+DEPEND="app-crypt/tpm-tools[pkcs11]
+ dev-libs/opencryptoki[tpm]
+ app-crypt/trousers
+ dev-libs/openssl:0=
+ "
+RDEPEND="${DEPEND}
+ || (
+ >=net-misc/openssh-9.3_p1-r1
+ >=net-misc/openssh-contrib-9.3_p1[-X509]
+ )"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-static
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}