summaryrefslogtreecommitdiff
path: root/app-crypt/monkeysphere
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/monkeysphere')
-rw-r--r--app-crypt/monkeysphere/Manifest3
-rw-r--r--app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch12
-rw-r--r--app-crypt/monkeysphere/monkeysphere-0.44.ebuild26
3 files changed, 28 insertions, 13 deletions
diff --git a/app-crypt/monkeysphere/Manifest b/app-crypt/monkeysphere/Manifest
index d803e64df89c..882e9af1b536 100644
--- a/app-crypt/monkeysphere/Manifest
+++ b/app-crypt/monkeysphere/Manifest
@@ -1,4 +1,5 @@
AUX monkeysphere-0.44-install-uncompressed-man-pages.patch 1580 BLAKE2B 54db4bdeb8d93406d6f9fa222118c98e0a1cfbbdaaf02f280024a41a9c4842aecbbcd6735cdc9ed9949e0e5463f8bf940b642b632c385d48d4dcf36a28a1cd69 SHA512 c4c677e08130ac01a3e98ba21f5e68e5bd7ce4765b44ed91ca5e0506d22937fc13f1a0dfdcd86f1e093e666882452b112a52b954d5f33ee73a47381a28d2e11c
+AUX monkeysphere-0.44-no-werror.patch 367 BLAKE2B dcdcd2c2cd885be72c798de70940f6d4789add8a7fc733b26dbc779d49f82fe192ca6f5ac11d3b9db971d58fd1e72d253626ac4699fc65c65051733695c90f5f SHA512 e9046056fcc5a4a07ef4c3ea8fa13bcad18c419318f61e6f07d66f7fd51c88e1fc073169cb5f7106d6f0af875e7afa46d10b41b975b63a4f60b32eb75e4f0c12
DIST monkeysphere_0.44.orig.tar.gz 110289 BLAKE2B 8a067035d3a40436fd5c27291ab25f15d475d9a0f17b51259c0431c77841807af93cb04d045b77c5f5dda3cd0061ab52561fdb62a704715d0d8cbbf96cb43259 SHA512 cb3c655a08b1c0a382502f8609f57d0c870fe4491b1b967e9931bdfd146b3926470496577949630452e073f04442b91a1ef679254c0f3091a834f3429e0f8e93
-EBUILD monkeysphere-0.44.ebuild 1079 BLAKE2B d464af629e7a4c91046bb6ff72c275f2b1b4ae8bdf3b8693d92877d3aa76209917e28441be92d553f506cad07f22e7155fc37e64f193f4a3fcfdfc33c9aa2568 SHA512 be037180395aaaeed4e1de486309f21e3ed7a73c6107ad96cec25493e3b09b1465640bd6881cf1b323c907f2540c50ed2010178a02566951065f6b192cc78e0b
+EBUILD monkeysphere-0.44.ebuild 1138 BLAKE2B 9cb51c5b2193d287bd9ce5bc466e493bc707ac2603beccaa26d9f6ff63ca101a97e7925856b3642437e316ac347911445ba805e9fd95747ffcb439ebac6293bd SHA512 8d34cd996e07a6d4fb3725972cf55d4dbd11aa6027f734a920793ab44272beb3393f210931946988beecd59f4c62f515717ce6d94a7c8152dce7571139048425
MISC metadata.xml 168 BLAKE2B 2e0e000b4c3b6ca04c12903fdbe278415c05a822623c52e9aa95cbbf3d50bcb1246b7edbda7d2f6b559af8950c6374e6e0a69b76319964cfe686bf50b0604a57 SHA512 4dcf45d1809e8390a2d8155c8ebfe0dd610203e392aeab0ccd8a10f42cc8532a4925eff32b35e7a6c35598a4efd288229034ec0732299dbd8cfa0acff705fed3
diff --git a/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch b/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch
new file mode 100644
index 000000000000..671045d7c385
--- /dev/null
+++ b/app-crypt/monkeysphere/files/monkeysphere-0.44-no-werror.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/832365
+--- a/Makefile
++++ b/Makefile
+@@ -17,7 +17,7 @@ LOCALSTATEDIR ?= /var/lib
+
+ CFLAGS += $(shell libassuan-config --cflags)
+ CFLAGS += $(shell libgcrypt-config --cflags)
+-CFLAGS += --pedantic -Wall -Werror -std=c99
++CFLAGS += --pedantic -Wall -std=c99
+ LIBS += $(shell libassuan-config --libs)
+ LIBS += $(shell libgcrypt-config --libs)
+
diff --git a/app-crypt/monkeysphere/monkeysphere-0.44.ebuild b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
index c22ae2b8f88c..f8a6c908946d 100644
--- a/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
+++ b/app-crypt/monkeysphere/monkeysphere-0.44.ebuild
@@ -1,22 +1,23 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit toolchain-funcs
+
DESCRIPTION="Leverage the OpenPGP web of trust for OpenSSH and Web authentication"
HOMEPAGE="http://web.monkeysphere.info/"
-
-LICENSE="GPL-3"
-SLOT="0/0"
-IUSE=""
SRC_URI="
mirror://debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz
http://archive.monkeysphere.info/debian/pool/monkeysphere/m/monkeysphere/monkeysphere_${PV}.orig.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="amd64 ~arm x86"
DOCS=( README Changelog )
-## Tests fail upstream for SSH connection. Issue has been reported.
+# Tests fail upstream for SSH connection. Issue has been reported.
RESTRICT="test"
DEPEND="acct-group/monkeysphere
@@ -26,19 +27,20 @@ DEPEND="acct-group/monkeysphere
dev-perl/Crypt-OpenSSL-RSA:0=
dev-perl/Digest-SHA1:0=
app-misc/lockfile-progs:0="
-
RDEPEND="${DEPEND}
net-misc/openssh"
-PATCHES=( "${FILESDIR}"/${PN}-0.44-install-uncompressed-man-pages.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.44-install-uncompressed-man-pages.patch
+ "${FILESDIR}"/${PN}-0.44-no-werror.patch
+)
src_prepare() {
default
- sed -i \
- -e "s#share/doc/monkeysphere#share/doc/${PF}#" \
- Makefile \
- || die
+ sed -i -e "s#share/doc/monkeysphere#share/doc/${PF}#" Makefile || die
+
+ tc-export CC
}
pkg_postinst() {