summaryrefslogtreecommitdiff
path: root/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild')
-rw-r--r--app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild13
1 files changed, 4 insertions, 9 deletions
diff --git a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
index 104c7ec0ef0d..6797a6c93d08 100644
--- a/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
+++ b/app-crypt/libu2f-host/libu2f-host-1.1.10.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit linux-info udev user
+inherit linux-info udev
DESCRIPTION="Yubico Universal 2nd Factor (U2F) Host C Library"
HOMEPAGE="https://developers.yubico.com/libu2f-host/"
@@ -16,20 +16,15 @@ IUSE="kernel_linux static-libs systemd"
DEPEND="dev-libs/hidapi
dev-libs/json-c:="
+# The U2F device node will be owned by group 'plugdev'
+# in non-systemd configurations
RDEPEND="${DEPEND}
+ !systemd? ( acct-group/plugdev )
systemd? ( sys-apps/systemd[acl] )"
BDEPEND="virtual/pkgconfig"
CONFIG_CHECK="~HIDRAW"
-pkg_setup() {
- # The U2F device node will be owned by group 'plugdev'
- # in non-systemd configurations
- if ! use systemd; then
- enewgroup plugdev
- fi
-}
-
src_install() {
default
if use kernel_linux; then