summaryrefslogtreecommitdiff
path: root/app-crypt/libsecret/libsecret-0.18.5.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libsecret/libsecret-0.18.5.ebuild')
-rw-r--r--app-crypt/libsecret/libsecret-0.18.5.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/app-crypt/libsecret/libsecret-0.18.5.ebuild b/app-crypt/libsecret/libsecret-0.18.5.ebuild
deleted file mode 100644
index aed7f8ac1079..000000000000
--- a/app-crypt/libsecret/libsecret-0.18.5.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-GCONF_DEBUG="yes"
-PYTHON_COMPAT=( python2_7 )
-VALA_USE_DEPEND=vapigen
-
-inherit gnome2 python-any-r1 vala virtualx
-
-DESCRIPTION="GObject library for accessing the freedesktop.org Secret Service API"
-HOMEPAGE="https://wiki.gnome.org/Projects/Libsecret"
-
-LICENSE="LGPL-2.1+ Apache-2.0" # Apache-2.0 license is used for tests only
-SLOT="0"
-
-IUSE="+crypt +introspection test vala"
-REQUIRED_USE="vala? ( introspection )"
-
-KEYWORDS="alpha amd64 arm ~arm64 ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd"
-
-RDEPEND="
- >=dev-libs/glib-2.38:2
- crypt? ( >=dev-libs/libgcrypt-1.2.2:0= )
- introspection? ( >=dev-libs/gobject-introspection-1.29:= )
-"
-PDEPEND=">=gnome-base/gnome-keyring-3
-"
-# PDEPEND to avoid circular dep (bug #547456)
-# gnome-keyring needed at runtime as explained at https://bugs.gentoo.org/475182#c2
-# Add ksecrets to PDEPEND when it's added to portage
-DEPEND="${RDEPEND}
- dev-libs/libxslt
- dev-util/gdbus-codegen
- >=dev-util/gtk-doc-am-1.9
- >=dev-util/intltool-0.35.0
- sys-devel/gettext
- virtual/pkgconfig
- test? (
- dev-python/mock
- introspection? (
- ${PYTHON_DEPS}
- >=dev-libs/gjs-1.32
- dev-python/pygobject:3 )
- )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- use vala && vala_src_prepare
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --enable-manpages \
- --disable-strict \
- --disable-coverage \
- --disable-static \
- $(use_enable crypt gcrypt) \
- $(use_enable introspection) \
- $(use_enable vala)
-}
-
-src_test() {
- Xemake check
-}