summaryrefslogtreecommitdiff
path: root/app-crypt/libmd/libmd-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/libmd/libmd-9999.ebuild')
-rw-r--r--app-crypt/libmd/libmd-9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/app-crypt/libmd/libmd-9999.ebuild b/app-crypt/libmd/libmd-9999.ebuild
index 7ce508a893c1..b28c93edaff6 100644
--- a/app-crypt/libmd/libmd-9999.ebuild
+++ b/app-crypt/libmd/libmd-9999.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools git-r3
+inherit autotools multilib-minimal git-r3
DESCRIPTION="Message Digest functions from BSD systems"
HOMEPAGE="https://www.hadrons.org/software/libmd/"
@@ -14,16 +14,14 @@ SLOT="0"
src_prepare() {
default
-
eautoreconf
}
-src_configure() {
- econf --disable-static
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf
}
-src_install() {
+multilib_src_install() {
default
-
- find "${ED}" -name '*.la' -delete || die
+ find "${ED}" -type f -name "*.la" -delete || die
}