summaryrefslogtreecommitdiff
path: root/app-crypt/gcr/gcr-3.41.1-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/gcr/gcr-3.41.1-r1.ebuild')
-rw-r--r--app-crypt/gcr/gcr-3.41.1-r1.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/app-crypt/gcr/gcr-3.41.1-r1.ebuild b/app-crypt/gcr/gcr-3.41.1-r1.ebuild
index ee7f1a92c62d..39aeeaaeb5c4 100644
--- a/app-crypt/gcr/gcr-3.41.1-r1.ebuild
+++ b/app-crypt/gcr/gcr-3.41.1-r1.ebuild
@@ -80,11 +80,14 @@ src_install() {
meson_src_install
# These files are installed by gcr:4
- rm \
- "${ED}"/usr/libexec/gcr-ssh-agent \
- "${ED}"/usr/lib/systemd/user/gcr-ssh-agent.service \
- "${ED}"/usr/lib/systemd/user/gcr-ssh-agent.socket \
- || die
+ local conflicts=(
+ "${ED}"/usr/libexec/gcr-ssh-agent
+ )
+ use systemd && conflicts+=(
+ "${ED}"/usr/lib/systemd/user/gcr-ssh-agent.{service,socket}
+ )
+ einfo "${conflicts[@]}"
+ rm "${conflicts[@]}" || die
if use gtk-doc; then
mkdir -p "${ED}"/usr/share/gtk-doc/html/ || die