summaryrefslogtreecommitdiff
path: root/app-crypt/codegroup/codegroup-20080907-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/codegroup/codegroup-20080907-r1.ebuild')
-rw-r--r--app-crypt/codegroup/codegroup-20080907-r1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/codegroup/codegroup-20080907-r1.ebuild b/app-crypt/codegroup/codegroup-20080907-r1.ebuild
new file mode 100644
index 000000000000..cf15b9cc4d11
--- /dev/null
+++ b/app-crypt/codegroup/codegroup-20080907-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="encode / decode binary file as five letter codegroups"
+HOMEPAGE="http://www.fourmilab.ch/codegroup/"
+SRC_URI="http://www.fourmilab.ch/${PN}/${PN}.zip -> ${P}.zip"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${P}-Makefile.patch )
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN}
+
+ doman ${PN}.1
+ dodoc ${PN}.{html,jpg}
+}