summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-nginx
diff options
context:
space:
mode:
Diffstat (limited to 'app-crypt/certbot-nginx')
-rw-r--r--app-crypt/certbot-nginx/Manifest2
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-3.2.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index 5dbff17d1ab2..43e0507dc00a 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,6 +1,8 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
DIST certbot-3.1.0.gh.tar.gz 2299990 BLAKE2B 596f11d4ebb161ee6ba67f4f150a77e081399f11f4e4652923c94297661149c9cb889afc51b46b6111847820823d90edc3a7f1e14c451122f88e6e777bf48795 SHA512 efd0b0c1540a6e3b631fa80eac65c9e8b31b1e5e1242f56d3723ca7e1b1b2121dfe1bf8e122fe9a9b994460553f1fa085b11d1369b3160f5c51c939b2cccd638
+DIST certbot-3.2.0.gh.tar.gz 2309823 BLAKE2B 30ff3f40dc4d7724ad7b9a5eaf48f15fa579d49902dd23d21d8b2d36a4371da05f8c9417b0b2bf49a12565ba9dec180a9d805f22e0e8d1342ae5ea64b43d5219 SHA512 8fc3753dcdc954e143da31a0308269b99abadcdefc008c54c2cabac14a3bf99e757f1007349806a7dabf4a8fe19fd3a365ddea85c1dbeb3b453ae91503ea2288
EBUILD certbot-nginx-2.10.0.ebuild 1164 BLAKE2B ff16d406ec7a3021a4bcd8e5c14ac019c403f30579a3ce2e969d58fd84eb8cca97917364276d84d005ff132b8f5b5e31cf6c1cfdf3c830f2b6d405fc268fb4dd SHA512 1b87b69774b282dae30d5ea4d54f1caac1a5de7d0e404ef7e4ced525465bf979cd695d59ea88f73caf7abd4f95224947ffe9771bfd529466ee78a267259f960a
EBUILD certbot-nginx-3.1.0.ebuild 1126 BLAKE2B f261f82c3ae26c88a5a7ee5ef73e360bf9dfa4f56b253860083db96d96eb41989796d9959e347acd45d757056bf9768aa42bc5c4c0570b57ebd19b29a04e09de SHA512 3e1831829dcc04b8b092aeddc286966128137983876bad3266a477406d947626a052d4175bb159c30b27131e3cab0092cae4c656986ac18e1bfd56efcaf12f12
+EBUILD certbot-nginx-3.2.0.ebuild 1094 BLAKE2B bf3198924825562244317e996d3ff234844b801121a4abc0fa416476c2707ad7094220a5d8cd4ff300257eb203a9473c061060b43d7dcca5df2b2336ef80642a SHA512 41764feba696a5a36b08af78f2c75d62d2d28c8dc523db35f953dc92b1dc2b0f98840b8de83908cb46a3a5c52834d4a593983c269af351312fee07eda38940b1
EBUILD certbot-nginx-9999.ebuild 1126 BLAKE2B 78734ec57887a381835175c5f7e93c19905babfe939790045d20e3fa8619c7e573e77c664c983355c1166f25539fdb2616a989f6530756a90366bc3b7559658c SHA512 c59de36e98b8e3c65999c2e6ecab212c886d116912b81c4feeccc802618b8f9ead6d4285b9de4751cd5bfdc3f2cbc509c586e43bd38c552541f9dcdeae30043b
MISC metadata.xml 386 BLAKE2B 563da29504a6d168cd88576a509ff6934a5002b50ad4d3157746fd438bfc32eb8ce031ada46136e3f4cfe3ff3a26eae28b0532eb32020da730a8f93310ce492e SHA512 04549f9c813962d55b8594593409f961865117d6c463c057dbfd7d71d1ea7c8ff64c991371a266df279ad0ac4b3c3d25f684860e28933e5a840345c34af51fb1
diff --git a/app-crypt/certbot-nginx/certbot-nginx-3.2.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-3.2.0.ebuild
new file mode 100644
index 000000000000..534fdfa7c618
--- /dev/null
+++ b/app-crypt/certbot-nginx/certbot-nginx-3.2.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot-nginx/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-25.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.4.7[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest