summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin8384 -> 8385 bytes
-rw-r--r--app-containers/catatonit/Manifest4
-rw-r--r--app-containers/catatonit/catatonit-0.1.7-r1.ebuild31
-rw-r--r--app-containers/catatonit/catatonit-9999.ebuild30
-rw-r--r--app-containers/catatonit/metadata.xml10
5 files changed, 74 insertions, 1 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index e17a85da725d..2a7dff7abde3 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/catatonit/Manifest b/app-containers/catatonit/Manifest
index 7171a1429850..a0f3499cfbf0 100644
--- a/app-containers/catatonit/Manifest
+++ b/app-containers/catatonit/Manifest
@@ -1,4 +1,6 @@
DIST catatonit-0.1.7-automake.patch 965 BLAKE2B fd42082321b75210653657cadd09751aa70a1eabeea4abc0cbc06aa91c510cff70d4261759407426a198f1aa3a1826d9f3a255d18e0e22e2dad53eca6b76ee87 SHA512 62cb75e8dcff7348eb5fe9dfb57627659bb755ffdd6a29b6d4e486e2b4c92945fa7420410941523585102ac11b14c2a1700fb6fd3fd663e7f38c10863f82fa87
DIST catatonit-0.1.7.tar.gz 21720 BLAKE2B ab73198e55dd06d3d0af04e6eff17a2f1e70ab1c0f9ec35f68f9afe71ce8cd1bdc3320e9728a6d8036c2251fe95028e1aad0838d1c9f51e4cc70e482a1109c24 SHA512 7d3174c60e1c8bd1f4b95b7751ccbe01cac63265060f18914b53311f68f7b4c63c693604f348ccfac5db4a96939169f835fbbbd614803b18062053d94f7dca67
+EBUILD catatonit-0.1.7-r1.ebuild 729 BLAKE2B c25be15f494565387b7742e9cfda9bc32e935f8bbf4d9c068919901f207aa5e76f54820d0dc9cbe88485585f3f39e16614c9016bcf8720d449d0ca531282d24a SHA512 24ae20bea03f95ee213311e682913474ef741819c139520070fb9e677c3b0d6acac54349f57253e43f7ec5304eac6d1c5d1b7ce86c0e4b7f122d6a0dbdc64f5a
EBUILD catatonit-0.1.7.ebuild 671 BLAKE2B 98de260f7abb37378f338eeed4f9bea1ae32e753e1d5fd6453a5f64438910d0937b9624ff6c3e601f780fb69b3e091cccc853108f1cf1b1e75fdcef75c40aca3 SHA512 c6aae6ccb517f8f25cd0504cecdb9680b2687dbb1eee35fababbe40429c764e272d8ac5cc5acda883759fb2a29d68524f253da201e2c1ebcc0491a9028370b7c
-MISC metadata.xml 302 BLAKE2B 25c8cfc1578a53cf585b81b225690f2b06a58cdec8fc6fdbbda943a9210924cb82a5552ace8e84edfd46a0ee186c71a273f318e53a201f6c46d7ea32577a8073 SHA512 1b504f841f32820714d82a565ceb2c1ebc43e484caf43d8d8a2b9e99d06bba1d9ae41bb2fc767f5512dbe3b09432a693b5a67767a40338e793009cf34c937a3d
+EBUILD catatonit-9999.ebuild 672 BLAKE2B d3a459ec7a834ff032bb5ba001800e684541f93e90c29058b7fd2efeb52c8d0f62ac1fc77f6c1096a99b3956735797006923244409d0b64e3fbf1dbdb121f564 SHA512 9e9829b254b8b4a0dec0b26d84540c8cfeddb4f8ef4b09b0b6219854326bae524ac9240289afe750135f9c2ec6341e0ac93677b7b4c4d9c421d784671136df9f
+MISC metadata.xml 697 BLAKE2B 8e152ca3568bb4264917ef25067ebe7f0600f62c830c86b9cc702b5822b022f189961dfbf28af241bdec9918524069b8de2c1e30cf40ee05662b8f76007625d4 SHA512 a7f414638c6ed400201c3c6caaa0c74e86ee3d4cfc9bf9f5abdc2d195fb44366c7d149f990712d07c848c13c145bf4a5660c7593e3d13540fd72aef8bf94c6a4
diff --git a/app-containers/catatonit/catatonit-0.1.7-r1.ebuild b/app-containers/catatonit/catatonit-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..ed448c4f8b05
--- /dev/null
+++ b/app-containers/catatonit/catatonit-0.1.7-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openSUSE/catatonit.git"
+else
+ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ sed -i -e 's|^AM_INIT_AUTOMAKE$||;' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym -r /usr/bin/"${PN}" /usr/libexec/podman/"${PN}"
+}
diff --git a/app-containers/catatonit/catatonit-9999.ebuild b/app-containers/catatonit/catatonit-9999.ebuild
new file mode 100644
index 000000000000..1531acd41b04
--- /dev/null
+++ b/app-containers/catatonit/catatonit-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A container init that is so simple it's effectively brain-dead"
+HOMEPAGE="https://github.com/openSUSE/catatonit"
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/openSUSE/catatonit.git"
+else
+ SRC_URI="https://github.com/openSUSE/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodir /usr/libexec/podman
+ dosym -r /usr/bin/"${PN}" /usr/libexec/podman/"${PN}"
+}
diff --git a/app-containers/catatonit/metadata.xml b/app-containers/catatonit/metadata.xml
index dd80ca2b54fb..e709b5447a7e 100644
--- a/app-containers/catatonit/metadata.xml
+++ b/app-containers/catatonit/metadata.xml
@@ -4,7 +4,17 @@
<maintainer type="person">
<email>zmedico@gentoo.org</email>
</maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
<upstream>
<remote-id type="github">openSUSE/catatonit</remote-id>
+ <bugs-to>https://github.com/openSUSE/catatonit/issues</bugs-to>
+ <doc>https://github.com/openSUSE/catatonit/blob/main/README.md</doc>
</upstream>
</pkgmetadata>