summaryrefslogtreecommitdiff
path: root/app-containers/podman/podman-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/podman/podman-9999.ebuild')
-rw-r--r--app-containers/podman/podman-9999.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/app-containers/podman/podman-9999.ebuild b/app-containers/podman/podman-9999.ebuild
index 2c7ededf36fd..f10c9b0ec10a 100644
--- a/app-containers/podman/podman-9999.ebuild
+++ b/app-containers/podman/podman-9999.ebuild
@@ -7,6 +7,7 @@ inherit go-module tmpfiles linux-info
DESCRIPTION="A tool for managing OCI containers and pods with Docker-compatible CLI"
HOMEPAGE="https://github.com/containers/podman/ https://podman.io/"
+
if [[ ${PV} == *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/podman.git"
@@ -14,6 +15,7 @@ else
SRC_URI="https://github.com/containers/podman/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~riscv"
fi
+
LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
SLOT="0"
IUSE="apparmor btrfs cgroup-hybrid wrapper +fuse +init +rootless +seccomp selinux systemd"
@@ -60,12 +62,12 @@ pkg_setup() {
src_prepare() {
default
local file
- for file in apparmor_tag btrfs_installed_tag btrfs_tag selinux_tag systemd_tag; do
+ for file in apparmor_tag btrfs_installed_tag btrfs_tag systemd_tag; do
[[ -f hack/"${file}".sh ]] || die
done
local feature
- for feature in apparmor selinux systemd; do
+ for feature in apparmor systemd; do
cat <<-EOF > hack/"${feature}"_tag.sh || die
#!/usr/bin/env bash
$(usex ${feature} "echo ${feature}" echo)