summaryrefslogtreecommitdiff
path: root/app-containers/nerdctl/nerdctl-1.3.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/nerdctl/nerdctl-1.3.1.ebuild')
-rw-r--r--app-containers/nerdctl/nerdctl-1.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-containers/nerdctl/nerdctl-1.3.1.ebuild b/app-containers/nerdctl/nerdctl-1.3.1.ebuild
new file mode 100644
index 000000000000..368d3359748d
--- /dev/null
+++ b/app-containers/nerdctl/nerdctl-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module
+
+EGIT_COMMIT="b224b280ff3086516763c7335fc0e0997aca617a"
+
+DESCRIPTION="Docker-compatible CLI for containerd, with support for Compose"
+HOMEPAGE="https://github.com/containerd/nerdctl"
+SRC_URI="
+ https://github.com/containerd/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/containerd/${PN}/releases/download/v${PV}/${P}-go-mod-vendor.tar.gz
+"
+
+LICENSE="Apache-2.0 BSD BSD-2 ISC MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd "${S}"
+ unpack "${P}-go-mod-vendor.tar.gz"
+}
+
+src_compile() {
+ emake VERSION=v${PV} REVISION="${EGIT_COMMIT}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" VERSION=v${PV} REVISION="${EGIT_COMMIT}" BINDIR="/usr/bin" install
+ DOCS=( README.md docs/* examples )
+ einstalldocs
+}