summaryrefslogtreecommitdiff
path: root/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch')
-rw-r--r--app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch b/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch
new file mode 100644
index 000000000000..74f3d353c561
--- /dev/null
+++ b/app-containers/lxc/files/lxc-5.0.0-dont-depend-on-static-libcap.patch
@@ -0,0 +1,27 @@
+From 7d72354898feac15bc4082130bcbe638bae02450 Mon Sep 17 00:00:00 2001
+From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+Date: Thu, 14 Jul 2022 17:03:40 +0200
+Subject: [PATCH] meson.build: fix build with -Dcapabilities=false
+
+Define libcap_static to an empty array to avoid the following build
+failure with -Dcapabilities=false:
+
+output/build/lxc-5.0.0/src/lxc/cmd/meson.build:64:4: ERROR: Unknown variable "libcap_static".
+
+Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
+---
+ meson.build | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/meson.build b/meson.build
+index 992fa08c72..4ed57a655b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -443,6 +443,7 @@ int main(int argc, char *argv[]) { return 0; };
+ srcconf.set10('HAVE_STATIC_LIBCAP', false)
+ endif
+ else
++ libcap_static = []
+ srcconf.set10('HAVE_LIBCAP', false)
+ srcconf.set10('HAVE_STATIC_LIBCAP', false)
+ endif