summaryrefslogtreecommitdiff
path: root/app-containers/docker/docker-23.0.1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/docker/docker-23.0.1.ebuild')
-rw-r--r--app-containers/docker/docker-23.0.1.ebuild42
1 files changed, 6 insertions, 36 deletions
diff --git a/app-containers/docker/docker-23.0.1.ebuild b/app-containers/docker/docker-23.0.1.ebuild
index e8c53f5f178b..d592dae8135b 100644
--- a/app-containers/docker/docker-23.0.1.ebuild
+++ b/app-containers/docker/docker-23.0.1.ebuild
@@ -14,8 +14,7 @@ SRC_URI="https://github.com/moby/moby/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
-IUSE="apparmor aufs btrfs +container-init device-mapper hardened
-overlay seccomp selinux"
+IUSE="apparmor aufs btrfs +container-init device-mapper overlay seccomp selinux"
DEPEND="
acct-group/docker
@@ -125,12 +124,12 @@ pkg_setup() {
fi
CONFIG_CHECK+="
- ~!LEGASY_SYSCALL_NATIVE
- ~LEGASY_SYSCALL_emulate
- ~!LEGASY_SYSCALL_none
+ ~!LEGACY_VSYSCALL_NATIVE
+ ~LEGACY_VSYSCALL_EMULATE
+ ~!LEGACY_VSYSCALL_NONE
"
- WARNING_LEGASY_SYSCALL_NONE="CONFIG_LEGASY_SYSCALL_NONE enabled: \
- Containers with <=glibc 2.13 will not work"
+ WARNING_LEGACY_SYSCALL_NONE="CONFIG_LEGACY_VSYSCALL_NONE enabled: \
+ Containers with <=glibc-2.13 will not work"
if kernel_is le 4 5; then
CONFIG_CHECK+="
@@ -253,14 +252,6 @@ src_compile() {
fi
done
- if use hardened; then
- sed -i "s/EXTLDFLAGS_STATIC='/&-fno-PIC /" hack/make.sh || die
- grep -q -- '-fno-PIC' hack/make.sh || die 'hardened sed failed'
- sed "s/LDFLAGS_STATIC_DOCKER='/&-extldflags -fno-PIC /" \
- -i hack/make/dynbinary-daemon || die
- grep -q -- '-fno-PIC' hack/make/dynbinary-daemon || die 'hardened sed failed'
- fi
-
# build daemon
./hack/make.sh dynbinary || die 'dynbinary failed'
}
@@ -320,27 +311,6 @@ pkg_postinst() {
elog " Check https://docs.docker.com/storage/storagedriver/zfs-driver for more info"
elog
fi
-
- if use cli; then
- ewarn "Starting with docker 20.10.2, docker has been split into"
- ewarn "two packages upstream, so Gentoo has followed suit."
- ewarn
- ewarn "app-containers/docker contains the daemon and"
- ewarn "app-containers/docker-cli contains the docker command."
- ewarn
- ewarn "docker currently installs docker-cli using the cli use flag."
- ewarn
- ewarn "This use flag is temporary, so you need to take the"
- ewarn "following actions:"
- ewarn
- ewarn "First, disable the cli use flag for app-containers/docker"
- ewarn
- ewarn "Then, if you need docker-cli and docker on the same machine,"
- ewarn "run the following command:"
- ewarn
- ewarn "# emerge --noreplace docker-cli"
- ewarn
- fi
}
pkg_postrm() {