summaryrefslogtreecommitdiff
path: root/app-containers/conmon/conmon-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/conmon/conmon-9999.ebuild')
-rw-r--r--app-containers/conmon/conmon-9999.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/app-containers/conmon/conmon-9999.ebuild b/app-containers/conmon/conmon-9999.ebuild
index 073e0db942c9..c41813b997a1 100644
--- a/app-containers/conmon/conmon-9999.ebuild
+++ b/app-containers/conmon/conmon-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -8,13 +8,12 @@ inherit toolchain-funcs
DESCRIPTION="An OCI container runtime monitor"
HOMEPAGE="https://github.com/containers/conmon"
-if [[ ${PV} == *9999* ]]; then
+if [[ ${PV} == 9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/containers/conmon.git"
else
SRC_URI="https://github.com/containers/conmon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
- GIT_COMMIT="00e08f4a9ca5420de733bf542b930ad58e1a7e7d"
fi
LICENSE="Apache-2.0"
@@ -33,31 +32,18 @@ PATCHES=(
src_prepare() {
default
- if use systemd; then
- sed -i -e 's|shell $(PKG_CONFIG) --exists libsystemd.* && echo "0"|shell echo "0"|g;' Makefile || die
- else
- sed -i -e 's|shell $(PKG_CONFIG) --exists libsystemd.* && echo "0"|shell echo "1"|g;' Makefile || die
- fi
-
- if use seccomp; then
- echo -e '#!/usr/bin/env bash\necho "0"' > hack/seccomp-notify.sh || die
- else
- echo -e '#!/usr/bin/env bash\necho "1"' > hack/seccomp-notify.sh || die
- fi
+ sed -i -e "s|shell.*--exists libsystemd.* && echo \"0\"|shell echo $(usex systemd 0 1)|g;" Makefile || die
+ echo -e "#!/usr/bin/env bash\necho $(usex seccomp 0 1)" > hack/seccomp-notify.sh || die
}
src_compile() {
tc-export CC PKG_CONFIG
- export PREFIX=${EPREFIX}/usr GOMD2MAN=go-md2man
- if [[ ${PV} == *9999* ]]; then
- default
- else
- emake GIT_COMMIT="${GIT_COMMIT}"
- fi
+ export PREFIX="${EPREFIX}/usr" GOMD2MAN=go-md2man
+ default
}
src_install() {
default
dodir /usr/libexec/podman
- dosym ../../bin/"${PN}" /usr/libexec/podman/conmon
+ dosym ../../bin/"${PN}" /usr/libexec/podman/"${PN}"
}