summaryrefslogtreecommitdiff
path: root/app-containers/buildah
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/buildah')
-rw-r--r--app-containers/buildah/Manifest3
-rw-r--r--app-containers/buildah/buildah-9999.ebuild123
-rw-r--r--app-containers/buildah/metadata.xml8
3 files changed, 133 insertions, 1 deletions
diff --git a/app-containers/buildah/Manifest b/app-containers/buildah/Manifest
index 4b3dcacbc138..db1c2bc800e3 100644
--- a/app-containers/buildah/Manifest
+++ b/app-containers/buildah/Manifest
@@ -4,4 +4,5 @@ DIST buildah-1.32.0.tar.gz 18445843 BLAKE2B d7471e3f0733bc626f665c592701666ba417
EBUILD buildah-1.29.1.ebuild 1194 BLAKE2B 585ad9104367142c5e3ade8d9418c23cafd752be0c000ca4079ac912d2f42b462e2ffba14c422362fee09146b73eacb409ad942cdba54751a21a31ed3e54ab89 SHA512 1ee657db211bfe245dd94fdb297d2f09bc03a70a35a460b3dabe77f0aa098bf9e5597387d2ff7125515e4610979f7587b7634c8d0f776c9ec25d676c4332e6a8
EBUILD buildah-1.30.0.ebuild 1196 BLAKE2B eefce023ce7e2662b1598fb3f6d5b885816d54a6397a788e10851b7ccc174ae6d9e4fa4ec387d3a21a7fdff4670ee68bfb59e9171e76032c3c28882d164cc446 SHA512 3c139484015e3e85c8f891babb375c560c3fc3e1827a44862eb262f95b8654a2c8d2a3c4102d3081c3a3677f20c0c5371a6579e9c0e1adfa339e5198475c357b
EBUILD buildah-1.32.0.ebuild 1958 BLAKE2B 20b9c0182b44e0a96891dc95f3ecb36a1a0bfc217c41eac2d8e613e35d54533ee3aa3bfc6314998350d5460f3a924282fab0b537dcc1fa3c9bef43be3a687819 SHA512 26cb4c1a9545c53a4c29021f672d844dd4ca6861aa0fc25b57b128798b2d19b72739ba77c6cc13c89a63f9089a7e56833dfb407e28de44b4cd0b19b9e70f4bdf
-MISC metadata.xml 463 BLAKE2B 3bf7f9e1a4c3dcc63dbfc39f987c159801795bd5b966a5845511592acdc8a5affbe82e4a2d3386890d5924922ab6f1f48c0eaaf40ba331650878d50bf455f39b SHA512 10da12fe2c20d7a20be7ddf7754d5deebcc41887e9d9317c662b781cab0c12ac0e1d72f9f4458bd3ed2c4a057a860c2c629abe5760b3c6c9dcd5e3402cde84e0
+EBUILD buildah-9999.ebuild 2938 BLAKE2B 0fd87b31771c1c2cfd2e9fc7e23eac32847edb52813f2d3c3110c624fb14536cb998376b6fd239a1bded8910e930cb0dfa467f05cfe24e9cc5579ac795c8fbd3 SHA512 083f0a8a64b2817c18d983ad28bb85aa47afb91e4722b23f902d3dded6ee2ad854e6c80b34500e73a5cad78ec3780ad4b998d934c589a2d0a42abb40df8f9079
+MISC metadata.xml 721 BLAKE2B 3ad3d8a1726282f73f0fdae72e1f970dfbfbc9fcbde5f589fb7285273312682af51ea04e49c70ccf83434640e9acd68ca8d1352ea28a41ce67134d4d8c5de304 SHA512 0a88ddaee2b20b157e2ab5a584a2f265f45aab2807e10dfc46a79cf1573cf7e2db56611dad8de425650d042606dc7ddfa52e758b08b710199c72986aa93e9dbd
diff --git a/app-containers/buildah/buildah-9999.ebuild b/app-containers/buildah/buildah-9999.ebuild
new file mode 100644
index 000000000000..8ca21b070f70
--- /dev/null
+++ b/app-containers/buildah/buildah-9999.ebuild
@@ -0,0 +1,123 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module linux-info
+
+DESCRIPTION="A tool that facilitates building OCI images"
+HOMEPAGE="https://github.com/containers/buildah"
+LICENSE="Apache-2.0 BSD BSD-2 CC-BY-SA-4.0 ISC MIT MPL-2.0"
+
+SLOT="0"
+IUSE="apparmor btrfs +seccomp systemd doc test"
+RESTRICT="test"
+EXTRA_DOCS=(
+ "CHANGELOG.md"
+ "CONTRIBUTING.md"
+ "README.md"
+ "install.md"
+ "troubleshooting.md"
+ "docs/tutorials"
+)
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/containers/buildah.git"
+else
+ SRC_URI="https://github.com/containers/buildah/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ GIT_COMMIT=2326d49
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+DEPEND="
+ systemd? ( sys-apps/systemd )
+ btrfs? ( sys-fs/btrfs-progs )
+ seccomp? ( sys-libs/libseccomp:= )
+ apparmor? ( sys-libs/libapparmor:= )
+ app-crypt/gpgme:=
+ dev-libs/libgpg-error:=
+ dev-libs/libassuan:=
+ sys-apps/shadow:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_pretend() {
+ local CONFIG_CHECK=""
+ use btrfs && CONFIG_CHECK+=" ~BTRFS_FS"
+ check_extra_config
+
+ linux_config_exists || ewarn "Cannot determine configuration of your kernel."
+}
+
+src_prepare() {
+ default
+
+ sed -i -e "s|/usr/local|${EPREFIX}/usr|g" Makefile docs/Makefile || die
+
+ [[ -f hack/libsubid_tag.sh ]] && echo -e '#!/usr/bin/env bash\necho libsubid' > hack/libsubid_tag.sh || die
+
+ [[ -f hack/apparmor_tag.sh ]] || die
+ if use apparmor; then
+ echo -e '#!/usr/bin/env bash\necho apparmor' > hack/apparmor_tag.sh || die
+ else
+ echo -e '#!/usr/bin/env bash\necho' > hack/apparmor_tag.sh || die
+ fi
+
+ use seccomp || {
+ cat << 'EOF' > "${T}/disable_seccomp.patch"
+--- Makefile
++++ Makefile
+@@ -5 +5 @@
+-SECURITYTAGS ?= seccomp $(APPARMORTAG)
++SECURITYTAGS ?= $(APPARMORTAG)
+EOF
+ eapply -p0 "${T}/disable_seccomp.patch" || die
+ }
+
+ [[ -f hack/systemd_tag.sh ]] || die
+ if use systemd; then
+ echo -e '#!/usr/bin/env bash\necho systemd' > hack/systemd_tag.sh || die
+ else
+ echo -e '#!/usr/bin/env bash\necho' > hack/systemd_tag.sh || die
+ fi
+
+ [[ -f btrfs_installed_tag.sh && -f btrfs_tag.sh ]] || die
+ if use btrfs; then
+ echo -e '#!/usr/bin/env bash\necho btrfs_noversion' > btrfs_tag.sh || die
+ echo -e '#!/usr/bin/env bash\necho' > btrfs_installed_tag.sh || die
+ else
+ echo -e '#!/usr/bin/env bash\necho exclude_graphdriver_btrfs' > btrfs_installed_tag.sh || die
+ echo -e '#!/usr/bin/env bash\necho' > btrfs_tag.sh || die
+ fi
+
+ use test || {
+ cat << 'EOF' > "${T}/disable_tests.patch"
+--- Makefile
++++ Makefile
+@@ -54 +54 @@
+-all: bin/buildah bin/imgtype bin/copy bin/tutorial docs
++all: bin/buildah docs
+EOF
+ eapply -p0 "${T}/disable_tests.patch" || die
+ }
+
+}
+
+src_compile() {
+ if [[ ${PV} == *9999* ]]; then
+ emake all
+ else
+ emake GIT_COMMIT=${GIT_COMMIT} all
+ fi
+}
+
+src_test() {
+ emake test-unit
+}
+
+src_install() {
+ default
+ emake DESTDIR="${D}" install.completions
+ use doc && dodoc -r "${EXTRA_DOCS[@]}"
+}
diff --git a/app-containers/buildah/metadata.xml b/app-containers/buildah/metadata.xml
index 43c78bf71431..f1677943e1bc 100644
--- a/app-containers/buildah/metadata.xml
+++ b/app-containers/buildah/metadata.xml
@@ -5,6 +5,14 @@
<email>zmedico@gentoo.org</email>
<name>Zac Medico</name>
</maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="person" proxied="yes">
+ <email>rahil3108@gmail.com</email>
+ <name>Rahil Bhimjiani</name>
+ </maintainer>
<upstream>
<remote-id type="github">containers/buildah</remote-id>
</upstream>