summaryrefslogtreecommitdiff
path: root/app-containers/buildah/buildah-1.33.7.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/buildah/buildah-1.33.7.ebuild')
-rw-r--r--app-containers/buildah/buildah-1.33.7.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/app-containers/buildah/buildah-1.33.7.ebuild b/app-containers/buildah/buildah-1.33.7.ebuild
index 60b99c3a6057..a24bd18a767c 100644
--- a/app-containers/buildah/buildah-1.33.7.ebuild
+++ b/app-containers/buildah/buildah-1.33.7.ebuild
@@ -60,15 +60,16 @@ src_prepare() {
cat <<'EOF' > "${T}/dont-call-as-directly-upstream-pr-5436.patch"
--- a/Makefile
+++ b/Makefile
-@@ -10,6 +10,7 @@
+@@ -10,6 +10,8 @@
BASHINSTALLDIR = $(PREFIX)/share/bash-completion/completions
BUILDFLAGS := -tags "$(BUILDTAGS)"
BUILDAH := buildah
+AS ?= as
++STRIP ?= strip
GO := go
GO_LDFLAGS := $(shell if $(GO) version|grep -q gccgo; then echo "-gccgoflags"; else echo "-ldflags"; fi)
-@@ -72,7 +73,7 @@
+@@ -72,11 +74,11 @@
bin/buildah: $(SOURCES) cmd/buildah/*.go internal/mkcw/embed/entrypoint.gz
$(GO_BUILD) $(BUILDAH_LDFLAGS) $(GO_GCFLAGS) "$(GOGCFLAGS)" -o $@ $(BUILDFLAGS) ./cmd/buildah
@@ -77,6 +78,11 @@ src_prepare() {
internal/mkcw/embed/entrypoint: internal/mkcw/embed/entrypoint.s
$(AS) -o $(patsubst %.s,%.o,$^) $^
$(LD) -o $@ $(patsubst %.s,%.o,$^)
+- strip $@
++ $(STRIP) $@
+ else
+ .PHONY: internal/mkcw/embed/entrypoint
+ endif
EOF
default
@@ -139,7 +145,7 @@ src_compile() {
# https://github.com/gentoo/gentoo/pull/33531#issuecomment-1786107493
[[ ${PV} != 9999* ]] && export COMMIT_NO="" GIT_COMMIT=""
- tc-export AS LD
+ tc-export AS LD STRIP
export GOMD2MAN="$(command -v go-md2man)"
default
}