summaryrefslogtreecommitdiff
path: root/app-containers/apptainer
diff options
context:
space:
mode:
Diffstat (limited to 'app-containers/apptainer')
-rw-r--r--app-containers/apptainer/Manifest2
-rw-r--r--app-containers/apptainer/apptainer-1.3.1.ebuild92
2 files changed, 94 insertions, 0 deletions
diff --git a/app-containers/apptainer/Manifest b/app-containers/apptainer/Manifest
index 381c147914e9..12fb0e11028a 100644
--- a/app-containers/apptainer/Manifest
+++ b/app-containers/apptainer/Manifest
@@ -1,4 +1,6 @@
AUX apptainer-1.0.2-trim_upstream_cflags.patch 1142 BLAKE2B 7238229b70a8ac37f3401a163d19dc705adb6a4ab6355e4eaa386ad5c639bfc1443cf61507112a53b66816399ca5fe2c32de964dd602ea16c5dfbf9003343f8c SHA512 1351ee000274567bb5a63aa740fbc43510d84ccad42c9af0c555943b99d93d86a2b036801c1681b93548a874bda1bab3304c2bf0da83bbca102a71e82574a032
DIST apptainer-1.3.0.tar.gz 17103544 BLAKE2B ed42b763a20b2b71cce6081b903697dc506073f91f9d928d49801165289d15c1416044af8fcedddcbd2a260c17a2e6488ed3d06b1edb4fb5f5ca5e9d14a14312 SHA512 a72afcac8e783f43732517314a94ffe039ab8f29027bcc398295fed97b123e6777039c016b6655a3cefbcba7e69832f62f3418b11e1bbd0452edc702ecaef69e
+DIST apptainer-1.3.1.tar.gz 17131707 BLAKE2B 08b25f188c8c0b3b72dd692ce9bb21ee5b40ad599170c12ec18b485a05a9b7309215ad17d2b2d15086f35864bf1d09dfd0834b7e2c8c54c5b175bb5989328022 SHA512 da24d7aac8b4a66c665f5d01a293a6de6ea214011a4f1b728c10fff03ee1e94beb648f3be04df072011dbac920624927ddbe2cf7c13a9aba424b463c51d2df64
EBUILD apptainer-1.3.0.ebuild 2462 BLAKE2B 497f8306a9cf565584cf8b0aeca3b4dd39a3bacb78b1373257aca172bebf9ce25bd58273970687ad2ef8f5e52886cae5e35191767ca95f064c3f92325d2a4346 SHA512 cfb415e29601c5b0a2c86f67bb5cf4b89cbc5ca933707d606c09f227014a7a925f0a2482be4e06ef1701a35c94a5df015bda2850d4fbf1ae2c96450fbb91ab6a
+EBUILD apptainer-1.3.1.ebuild 2463 BLAKE2B 0ac11be5ab4bbf1fe0cf770c416e8f79efd95c5b998aa8a1457d27f5a38310b29298538c120a20f51f47f56732beb3c8884ac3012c75cf602891dd7c97ff1640 SHA512 f8ca6ec4ee64adb10398874120946a25852130b8ed27d415668990fe3144655c619e041ce2a7a59026580fa9f5842e34b9e1089f24f1b915557cb5533c8041ad
MISC metadata.xml 454 BLAKE2B 7891b6acae30424b8b6877166b856c1113a13e40ebec9051935df10a0650bf941f52d75bdb6a4258795e07b080082979469b8b8242d2ddd56c52f9c5b6759f0e SHA512 ef53c2dee45734f36403ab71549494f3c24707bc183353e4bd9c548a97b3ab5d7877f4fc9d311d9e86ab249cbdb379f0a1a211ee36afda99fd552f0a5cac30bb
diff --git a/app-containers/apptainer/apptainer-1.3.1.ebuild b/app-containers/apptainer/apptainer-1.3.1.ebuild
new file mode 100644
index 000000000000..144ecd780c6e
--- /dev/null
+++ b/app-containers/apptainer/apptainer-1.3.1.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info toolchain-funcs
+
+DESCRIPTION="The container system for secure high-performance computing"
+HOMEPAGE="https://apptainer.org/"
+SRC_URI="https://github.com/apptainer/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples +network suid systemd"
+
+# Do not complain about CFLAGS etc. since go projects do not use them.
+QA_FLAGS_IGNORED='.*'
+
+DEPEND="app-crypt/gpgme
+ >=dev-lang/go-1.20.0
+ dev-libs/openssl
+ sys-apps/util-linux
+ sys-fs/cryptsetup
+ sys-fs/squashfs-tools
+ sys-libs/libseccomp
+ !suid? (
+ sys-fs/e2fsprogs[fuse]
+ sys-fs/squashfuse
+ )"
+RDEPEND="${DEPEND}
+ !sys-cluster/singularity"
+BDEPEND="virtual/pkgconfig"
+
+CONFIG_CHECK="~SQUASHFS"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.2-trim_upstream_cflags.patch
+)
+
+DOCS=( README.md CONTRIBUTORS.md CONTRIBUTING.md )
+
+src_configure() {
+ local myconfargs=(
+ -c "$(tc-getBUILD_CC)" \
+ -x "$(tc-getBUILD_CXX)" \
+ -C "$(tc-getCC)" \
+ -X "$(tc-getCXX)" \
+ --prefix="${EPREFIX}"/usr \
+ --sysconfdir="${EPREFIX}"/etc \
+ --runstatedir="${EPREFIX}"/run \
+ --localstatedir="${EPREFIX}"/var \
+ $(usex network "" "--without-network") \
+ $(use_with suid)
+ )
+ ./mconfig -v ${myconfargs[@]} || die "Error invoking mconfig"
+}
+
+src_compile() {
+ emake -C builddir
+}
+
+src_install() {
+ emake DESTDIR="${D}" -C builddir install
+ keepdir /var/${PN}/mnt/session
+
+ if use systemd; then
+ sed -i -e '/systemd cgroups/ s/no/yes/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to enable systemd use in configuration"
+ else
+ sed -i -e '/systemd cgroups/ s/yes/no/' "${ED}"/etc/${PN}/${PN}.conf \
+ || die "Failed to disable systemd use in configuration"
+ fi
+
+ einstalldocs
+ if use examples; then
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ if ! use suid; then
+ local oldver
+ for oldver in ${REPLACING_VERSIONS}; do
+ if ver_test "${oldver}" -lt 1.1.0; then
+ ewarn "Since version 1.1.0 ${PN} no longer installs setuid-root components by default, relying on unprivileged user namespaces instead. For details, see https://apptainer.org/docs/admin/main/user_namespace.html"
+ ewarn "Make sure user namespaces (possibly except network ones for improved security) are enabled on your system, or re-enable installation of setuid root components by passing USE=suid to ${CATEGORY}/${PN}"
+ break
+ fi
+ done
+ fi
+}