summaryrefslogtreecommitdiff
path: root/app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild')
-rw-r--r--app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild b/app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild
new file mode 100644
index 000000000000..7cd8392b5cfb
--- /dev/null
+++ b/app-cdr/dumpet/dumpet-2.1_p20140601-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vcs-snapshot
+
+COMMIT="8f47670dd582c96ad1b6dd3c9b9da0acebded5d8"
+
+DESCRIPTION="A tool to dump and debug bootable CD-like images"
+HOMEPAGE="https://github.com/rhboot/dumpet"
+SRC_URI="https://github.com/rhboot/dumpet/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+#Restrict tests since required test file is unavailable
+RESTRICT="test"
+
+RDEPEND="dev-libs/libxml2
+ dev-libs/popt"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-util/valgrind )"
+
+src_prepare() {
+ sed -i Makefile \
+ -e "s/^install : all$/install :/" \
+ -e "s/^CFLAGS:=/CFLAGS?=/" \
+ -e "s/^CC:=/CC?=/" \
+ || die
+ default
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" dumpet
+}
+
+pkg_setup(){
+ tc-export CC
+}