summaryrefslogtreecommitdiff
path: root/app-cdr/bchunk
diff options
context:
space:
mode:
Diffstat (limited to 'app-cdr/bchunk')
-rw-r--r--app-cdr/bchunk/Manifest5
-rw-r--r--app-cdr/bchunk/bchunk-1.2.0-r4.ebuild21
-rw-r--r--app-cdr/bchunk/files/CVE-2017-15953.patch25
-rw-r--r--app-cdr/bchunk/files/CVE-2017-15955.patch32
-rw-r--r--app-cdr/bchunk/metadata.xml7
5 files changed, 90 insertions, 0 deletions
diff --git a/app-cdr/bchunk/Manifest b/app-cdr/bchunk/Manifest
new file mode 100644
index 000000000000..7f2c16e31b7c
--- /dev/null
+++ b/app-cdr/bchunk/Manifest
@@ -0,0 +1,5 @@
+AUX CVE-2017-15953.patch 738 BLAKE2B a7d35373ff5fc7f105430c6480285fe567a2ecd4cf6979b0e950a0945e9cdbe78aeab9815b628af6e398d1a57ae94ebbd8ec829b01a43bc33baa434ef4863b41 SHA512 266dc695cbc53a58f99cef7bff8e399a018275dce05d50edb4465096c418fa4d77850c671b56a3656f942f0affd83110f341c91bb325d48b9d264b5370b99a51
+AUX CVE-2017-15955.patch 773 BLAKE2B ed4a57da8a73cdde213a5b6e7b454d067ac7b178d1919490657ca0a2ba095ca0b2ae05dfe929d4ee92fa6a2fc7861215cddb9f5d6727d460f6a44b18b9f38581 SHA512 060d6d637f5af2507d63edea4bdda30ae4d6fa5b8e96aaac6d9e41fe328d474bf6854fea101fd6de878ea3b5f2f3e2ccdd1b8e1182a55fe423f293b2024dc7f1
+DIST bchunk-1.2.0.tar.gz 15078 BLAKE2B 60d443380ffaa8dd1d025777c91c1374a931f16c8de2219a4ff453ee4d7c6eb235b2380ce1021911636d247a12640214dc40b29f9c9cf917ff4bc4594f189fc4 SHA512 0e1f9daa2dfeff58e2c65ac2767bff804811fa22f70a220747aa873cb01b77b4c6a809736483aa22fb3f2d2a88885469d10fb45af4626069e992a0763a5fcc2d
+EBUILD bchunk-1.2.0-r4.ebuild 584 BLAKE2B e6cadb8e14ffb69db005f27c76dfaa7eb77db351b5293d084d948b52304cbd6e6f54a67d31fa24f2fac30e04130ce78f19eab37a03c426f289b858478addb65b SHA512 1eaf7fdb44aec8579926280b8fd9b5eb4f3841cd2ec6c89d6ad097709029b8d0108abcbd79b64a517a48e93f4244f8a6ddd6bc35bc5b3f2fc289eeb846be772b
+MISC metadata.xml 316 BLAKE2B f234f603d9fcf3c50f48602826b361707317ec2dd0ca1438224e6ec753e92bd0c024d773343c6b6413a920698f4673b85cf6b6411a0c53dc02253b5e341da236 SHA512 1a2c6992e5957694c18634dd12d5a567d1bd74b063f91e7c524984722955a0a72ff22ff2ef17932eb2eafd84d4493dbe6a103df3fad70e4134fa33ddcc3463e9
diff --git a/app-cdr/bchunk/bchunk-1.2.0-r4.ebuild b/app-cdr/bchunk/bchunk-1.2.0-r4.ebuild
new file mode 100644
index 000000000000..846db0b7f490
--- /dev/null
+++ b/app-cdr/bchunk/bchunk-1.2.0-r4.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Convert CD images from bin/cue to iso+wav/cdr"
+HOMEPAGE="http://he.fi/bchunk/"
+SRC_URI="${HOMEPAGE}${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+
+DOCS=( "${P}.lsm" "${PN}.spec" README ChangeLog )
+PATCHES=( "${FILESDIR}/CVE-2017-15953.patch" "${FILESDIR}/CVE-2017-15955.patch" )
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}
diff --git a/app-cdr/bchunk/files/CVE-2017-15953.patch b/app-cdr/bchunk/files/CVE-2017-15953.patch
new file mode 100644
index 000000000000..f78bb7178af2
--- /dev/null
+++ b/app-cdr/bchunk/files/CVE-2017-15953.patch
@@ -0,0 +1,25 @@
+--- a/bchunk.c 2017-10-30 18:03:58.658741629 +0000
++++ b/bchunk.c 2017-10-30 19:40:25.558131619 +0000
+@@ -18,6 +18,7 @@
+ * Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+@@ -271,11 +272,10 @@
+ int16_t i;
+ float fl;
+
+- if (!(fname = malloc(strlen(bname) + 8))) {
+- fprintf(stderr, "main(): malloc() failed, out of memory\n");
++ if (asprintf(&fname, "%s%2.2d.%s", bname, track->num, track->extension) == -1) {
++ fprintf(stderr, "writetrack(): asprintf() failed, out of memory\n");
+ exit(4);
+ }
+- sprintf(fname, "%s%2.2d.%s", bname, track->num, track->extension);
+
+ printf("%2d: %s ", track->num, fname);
+
+
diff --git a/app-cdr/bchunk/files/CVE-2017-15955.patch b/app-cdr/bchunk/files/CVE-2017-15955.patch
new file mode 100644
index 000000000000..85797fe020af
--- /dev/null
+++ b/app-cdr/bchunk/files/CVE-2017-15955.patch
@@ -0,0 +1,32 @@
+--- a/bchunk.c 2017-10-30 18:03:58.658741629 +0000
++++ b/bchunk.c 2017-10-30 19:17:36.732855884 +0000
+@@ -426,11 +426,11 @@
+ printf("\nTrack ");
+ if (!(p = strchr(p, ' '))) {
+ fprintf(stderr, "... ouch, no space after TRACK.\n");
+- continue;
++ exit(3);
+ }
+ p++;
+ if (!(t = strchr(p, ' '))) {
+ fprintf(stderr, "... ouch, no space after track number.\n");
+- continue;
++ exit(3);
+ }
+ *t = '\0';
+
+@@ -460,12 +460,12 @@
+ } else if ((p = strstr(s, "INDEX"))) {
+ if (!(p = strchr(p, ' '))) {
+ printf("... ouch, no space after INDEX.\n");
+- continue;
++ exit(3);
+ }
+ p++;
+ if (!(t = strchr(p, ' '))) {
+ printf("... ouch, no space after index number.\n");
+- continue;
++ exit(3);
+ }
+ *t = '\0';
+ t++; \ No newline at end of file
diff --git a/app-cdr/bchunk/metadata.xml b/app-cdr/bchunk/metadata.xml
new file mode 100644
index 000000000000..9807a3e2fa77
--- /dev/null
+++ b/app-cdr/bchunk/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!--maintainer-needed-->
+<longdescription>binchunker converts a CD image in a ".bin / .cue" format
+(sometimes ".raw / .cue") to a set of .iso and .cdr tracks.</longdescription>
+</pkgmetadata>