summaryrefslogtreecommitdiff
path: root/app-benchmarks/os-autoinst
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/os-autoinst')
-rw-r--r--app-benchmarks/os-autoinst/Manifest2
-rw-r--r--app-benchmarks/os-autoinst/os-autoinst-9999.ebuild29
2 files changed, 14 insertions, 17 deletions
diff --git a/app-benchmarks/os-autoinst/Manifest b/app-benchmarks/os-autoinst/Manifest
index 99aee2f241a1..be62c838ea27 100644
--- a/app-benchmarks/os-autoinst/Manifest
+++ b/app-benchmarks/os-autoinst/Manifest
@@ -1,2 +1,2 @@
-EBUILD os-autoinst-9999.ebuild 723 BLAKE2B 59a87b78f10d3cf278e642cbe7612dfea01916829ca68524ad3fb868f54869e75a15443d59f8dc7b624a8a212d88288f249de87a52895ffc0b42fda16992f7c4 SHA512 40aae61c2c6517ad5e48f038285afab920106becdad880e355c821e9417580714470fa44003ba6772a9aa18917428195cd713c886adb924c64224ca3c72e18b5
+EBUILD os-autoinst-9999.ebuild 747 BLAKE2B c04a2c5bbd3352c2276f76fe498239d681ec95c50be3c80c9ee53becf18c3515379eae6638bee116ad83f774577e36ef06197d86acc77da4d91b25f0f374652e SHA512 91a7ecafdcf241312fb87c7af2a623daa1b8d184cbf438848f6bd07195773c094b057d27b19573b0117a082b7a18342594b2d2b14815968f5fc9d2c30f0fc8d4
MISC metadata.xml 232 BLAKE2B c631433a9b129e3e3b7cd485e9ec345264bf2f22f7f64193d5955987c5b44339d36356c8e17c2ded1c8f771774a0811ee41f12ca699a947bf2faf183805c4c1b SHA512 23824ca618f16dec558197c0c853f3ebf5c0f1b034635242282bd40f01beea59cbac3b416e86f2eb4337942d9db945a2e1fd4fe52c88762b65749855762769fa
diff --git a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
index 2f46d77f4b83..f9dca04f3834 100644
--- a/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
+++ b/app-benchmarks/os-autoinst/os-autoinst-9999.ebuild
@@ -1,44 +1,41 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=6
-EGIT_REPO_URI="git://gitorious.org/os-autoinst/os-autoinst.git"
-
-inherit git-2 autotools eutils
+inherit autotools git-r3
DESCRIPTION="automated testing of Operating Systems"
HOMEPAGE="http://os-autoinst.org/"
-SRC_URI=""
+EGIT_REPO_URI="https://github.com/os-autoinst/os-autoinst.git"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-IUSE=""
DEPEND="
- >=media-libs/opencv-2.4
-"
+ media-libs/libogg:=
+ media-libs/libsndfile:=
+ media-libs/libtheora:=
+ >=media-libs/opencv-2.4:=
+ sci-libs/fftw:3.0="
RDEPEND="${DEPEND}
dev-lang/perl[ithreads]
dev-perl/JSON
app-emulation/qemu
app-text/gocr
media-gfx/imagemagick
- media-video/ffmpeg2theora
-"
+ media-video/ffmpeg2theora"
src_prepare() {
+ default
eautoreconf
}
src_configure() {
- econf \
- --docdir="${EPREFIX}/usr/share/doc/${PF}" \
- --disable-static
+ econf --disable-static
}
src_install() {
default
- prune_libtool_files --all
+ find "${D}" -name '*.la' -delete || die
}