summaryrefslogtreecommitdiff
path: root/app-benchmarks/hey/hey-0.1.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/hey/hey-0.1.2.ebuild')
-rw-r--r--app-benchmarks/hey/hey-0.1.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-benchmarks/hey/hey-0.1.2.ebuild b/app-benchmarks/hey/hey-0.1.2.ebuild
new file mode 100644
index 000000000000..639ee500ec44
--- /dev/null
+++ b/app-benchmarks/hey/hey-0.1.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit go-module
+
+DESCRIPTION="HTTP load generator, ApacheBench (ab) replacement, formerly known as rakyll/boom"
+HOMEPAGE="https://github.com/rakyll/hey"
+SRC_URI="https://github.com/rakyll/hey/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="Apache-2.0 BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ export -n GOCACHE XDG_CACHE_HOME
+ go build -o ./bin/${PN} || die
+}
+
+src_install() {
+ dobin ./bin/${PN}
+ dodoc README.md
+}