summaryrefslogtreecommitdiff
path: root/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild')
-rw-r--r--app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild3
1 files changed, 2 insertions, 1 deletions
diff --git a/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
index 2ab46e265b61..075d22f8e1b7 100644
--- a/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
+++ b/app-benchmarks/bonnie/bonnie-2.0.6-r3.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Performance Test of Filesystem I/O using standard C library calls"
HOMEPAGE="https://www.textuality.com/bonnie/"
@@ -22,6 +22,7 @@ PATCHES=(
src_compile() {
tc-export CC
+ append-cflags -std=gnu89 # old codebase, incompatible with c2x
emake -f /dev/null Bonnie
}