summaryrefslogtreecommitdiff
path: root/app-backup/tarsnap/tarsnap-1.0.39.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/tarsnap/tarsnap-1.0.39.ebuild')
-rw-r--r--app-backup/tarsnap/tarsnap-1.0.39.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/app-backup/tarsnap/tarsnap-1.0.39.ebuild b/app-backup/tarsnap/tarsnap-1.0.39.ebuild
index 42bf7639963d..2d6ba5fde749 100644
--- a/app-backup/tarsnap/tarsnap-1.0.39.ebuild
+++ b/app-backup/tarsnap/tarsnap-1.0.39.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-inherit bash-completion-r1
+inherit bash-completion-r1 toolchain-funcs
DESCRIPTION="Online backups for the truly paranoid"
HOMEPAGE="https://www.tarsnap.com/"
@@ -26,6 +26,8 @@ RDEPEND="
DEPEND="${RDEPEND}
virtual/os-headers" # Required for "magic.h"
+PATCHES=( "${FILESDIR}"/${PN}-1.0.39-respect-AR.patch )
+
S=${WORKDIR}/${PN}-autoconf-${PV}
src_configure() {
@@ -37,6 +39,10 @@ src_configure() {
$(use_with lzma)
}
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
src_install() {
default
dobashcomp misc/bash_completion.d/*