summaryrefslogtreecommitdiff
path: root/app-backup/dar
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/Manifest2
-rw-r--r--app-backup/dar/dar-2.7.17.ebuild97
2 files changed, 99 insertions, 0 deletions
diff --git a/app-backup/dar/Manifest b/app-backup/dar/Manifest
index 8a5659d0f6c8..fd0e3e26885a 100644
--- a/app-backup/dar/Manifest
+++ b/app-backup/dar/Manifest
@@ -1,3 +1,5 @@
DIST dar-2.7.16.tar.gz 2444321 BLAKE2B 019f441fe5ca951fbb43b661cbc9d6c5c1992e825005fb434579b2dedb6dc379593ffa11a1ee651da6047c16b8264a19dbbbc7e98bb2d20790890058f245a03c SHA512 bc70aecc05641314144c9a252fec1d256b3a19e38837ee2bb1320bfc7b659bc1e7399e6e1377862e25d25c798fdf90e535794d8ba68f0b9754d9e6bfb9cb50fe
+DIST dar-2.7.17.tar.gz 2444942 BLAKE2B 62f99e75d3657a70f24513aafb9681ab235269931ba4eb5d893440746b393c8ac59938d5643ce50e4dd8d37a6672e7d6760cb67348239271dcfb4404abd862bd SHA512 99501e31e1c438ef4406e6bccc190b39b4313e2074adfb02e3f205d225f2292a58aded631e5df3320a11f6313106cf8128f522f3975d8a53eb1a5a6971d946ff
EBUILD dar-2.7.16.ebuild 2321 BLAKE2B efa5622fd8d5ad244fc0bfb3c220dfbd1699f2ba630dfabbdc4d9c3215377845eed31e8d3433be66ad911b8762c0c4f8af405291593864612a4ae0f631dd09e3 SHA512 3042dcae7bf39b6873f4b13d2fa3c53ab86aa0aeef85fec861b63c11b9ce5c632f841387286be0b3a2707e5bb00eca9135f87a3fb1a65763bf22a9a2b46eab71
+EBUILD dar-2.7.17.ebuild 2325 BLAKE2B a93aacc9bab4d980c80a6e4ac1e85ad8a8f6d9cf1c6b314c558ea0f5b7f76e4b42593d6475037915718fef140363d4bcf67f0bf6d37db7ab58bae6e185ee6d93 SHA512 f67bdc09dcf3f4b9863535648fd9d77afdcef3b6f0c3698107a7e33f2df393128e41f138116a44013f72a45676fccbc02ece35f7be62c9b499a12601ec7fb251
MISC metadata.xml 1180 BLAKE2B d978c1b969e7aeb013862c6b76ceb7b466af7b0a16d334bfbaafcdb49e13b4f07727073ff8a24da0f0422161f48805310b8ed7c0cc97b07190b241ad77cec254 SHA512 f8107b5f81d0d00a1873089b084250c98094625274b9c01f8ca11f6dcfa890278ec89d039849c203ccccc8115d54ee3f9365d9f6afc38cb3411f6292c62c11c0
diff --git a/app-backup/dar/dar-2.7.17.ebuild b/app-backup/dar/dar-2.7.17.ebuild
new file mode 100644
index 000000000000..b38bd31ffe37
--- /dev/null
+++ b/app-backup/dar/dar-2.7.17.ebuild
@@ -0,0 +1,97 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="https://downloads.sourceforge.net/project/dar/dar/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux"
+IUSE="argon2 curl dar32 dar64 doc gcrypt gpg lz4 lzo nls rsync xattr"
+
+REQUIRED_USE="
+ ?? ( dar32 dar64 )
+ gpg? ( gcrypt )
+"
+
+RESTRICT="test" # need to be run as root
+
+RDEPEND="
+ app-arch/bzip2:=
+ app-arch/xz-utils
+ app-arch/zstd:=
+ dev-libs/libthreadar
+ sys-libs/libcap
+ >=sys-libs/zlib-1.2.3:=
+ argon2? ( app-crypt/argon2:= )
+ curl? ( net-misc/curl )
+ gcrypt? (
+ dev-libs/libgcrypt:0=
+ dev-libs/libgpg-error
+ )
+ gpg? (
+ app-crypt/gpgme:=
+ dev-libs/libassuan:=
+ )
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:2 )
+ nls? ( virtual/libintl )
+ rsync? ( net-libs/librsync:= )
+ xattr? ( sys-apps/attr )
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ doc? ( app-text/doxygen )
+ nls? ( sys-devel/gettext )
+"
+
+QA_PKGCONFIG_VERSION="" # Bug #862025 - upstream has a different numbering scheme for libdar
+
+src_configure() {
+ # configure.ac is totally funked up regarding the AC_ARG_ENABLE
+ # logic.
+ # For example "--enable-dar-static" causes configure to DISABLE
+ # static builds of dar.
+ # Do _not_ use $(use_enable) until you have verified that the
+ # logic has been fixed by upstream.
+ local myconf=(
+ --disable-dar-static
+ --disable-python-binding
+ --disable-upx
+ $(usev !argon2 --disable-libargon2-linking)
+ $(usev !curl --disable-libcurl-linking)
+ $(usev dar32 --enable-mode=32)
+ $(usev dar64 --enable-mode=64)
+ $(usev !doc --disable-build-html)
+ $(usev !gcrypt --disable-libgcrypt-linking)
+ $(usev !gpg --disable-gpgme-linking)
+ $(usev !lz4 --disable-liblz4-linking)
+ $(usev !lzo --disable-liblzo2-linking)
+ $(usev !nls --disable-nls)
+ $(usev !rsync --disable-librsync-linking)
+ $(usev !xattr --disable-ea-support)
+ )
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir="${EPREFIX}"/usr/share/doc/${PF}/html install
+
+ einstalldocs
+
+ find "${ED}" -name "*.la" -delete || die
+
+ # Bug 729150
+ rm "${ED}/usr/share/doc/${PF}/html/samples/MyBackup.sh.tar.gz" || die
+}