summaryrefslogtreecommitdiff
path: root/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild')
-rw-r--r--app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild b/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild
new file mode 100644
index 000000000000..325844f806bd
--- /dev/null
+++ b/app-backup/borgbackup/borgbackup-1.1.17-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/${PN}/borg.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Deduplicating backup program with compression and authenticated encryption"
+HOMEPAGE="https://borgbackup.readthedocs.io/"
+
+LICENSE="BSD"
+SLOT="0"
+
+# Unfortunately we have a file conflict with app-office/borg, bug #580402
+RDEPEND="
+ !!app-office/borg
+ app-arch/lz4
+ virtual/acl
+ dev-python/llfuse[${PYTHON_USEDEP}]
+ dev-libs/openssl:0=
+"
+
+DEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}
+"
+
+src_install() {
+ distutils-r1_src_install
+ doman docs/man/*
+}