summaryrefslogtreecommitdiff
path: root/app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch')
-rw-r--r--app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch b/app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch
new file mode 100644
index 000000000000..9d3cf8092e1c
--- /dev/null
+++ b/app-backup/bareos/files/bareos-20.0.2-cmake-gentoo.patch
@@ -0,0 +1,24 @@
+diff -urw bareos-Release-20.0.2.orig/core/cmake/distname.sh bareos-Release-20.0.2/core/cmake/distname.sh
+--- bareos-Release-20.0.2.orig/core/cmake/distname.sh 2021-06-10 06:07:18.000000000 -0930
++++ bareos-Release-20.0.2/core/cmake/distname.sh 2021-08-15 17:07:37.168216517 -0930
+@@ -153,7 +153,7 @@
+ elif test -f /etc/gentoo-release
+ then
+ PLATFORM=gentoo
+- DISTVER=`awk '/version / { print $5 }' < /etc/gentoo-release`
++ DISTVER=`awk '/release / { print $5 }' < /etc/gentoo-release`
+ elif test -f /etc/debian_version
+ then
+ if `test -f /etc/apt/sources.list && grep -q ubuntu /etc/apt/sources.list`; then
+diff -urw bareos-Release-20.0.2.orig/core/platforms/CMakeLists.txt bareos-Release-20.0.2/core/platforms/CMakeLists.txt
+--- bareos-Release-20.0.2.orig/core/platforms/CMakeLists.txt 2021-06-10 06:07:18.000000000 -0930
++++ bareos-Release-20.0.2/core/platforms/CMakeLists.txt 2021-08-15 17:07:37.549226558 -0930
+@@ -30,6 +30,8 @@
+ message(STATUS "adding subdirectories debian and univention")
+ add_subdirectory(debian)
+ add_subdirectory(univention)
++ elseif(${PLATFORM} STREQUAL gentoo)
++ message(STATUS "PLATFORM: " ${PLATFORM})
+ elseif(${PLATFORM} STREQUAL hpux)
+ message(STATUS "PLATFORM: " ${PLATFORM})
+ elseif(${PLATFORM} STREQUAL archlinux)