summaryrefslogtreecommitdiff
path: root/app-backup/backintime/backintime-9999.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-backup/backintime/backintime-9999.ebuild')
-rw-r--r--app-backup/backintime/backintime-9999.ebuild26
1 files changed, 14 insertions, 12 deletions
diff --git a/app-backup/backintime/backintime-9999.ebuild b/app-backup/backintime/backintime-9999.ebuild
index 606f837db53d..ec4851aa691d 100644
--- a/app-backup/backintime/backintime-9999.ebuild
+++ b/app-backup/backintime/backintime-9999.ebuild
@@ -13,7 +13,6 @@ EGIT_REPO_URI="https://github.com/bit-team/backintime/"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="examples qt5"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -22,49 +21,52 @@ DEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/dbus-python[${PYTHON_USEDEP}]
dev-python/keyring[${PYTHON_USEDEP}]
- ')
+ ')"
+RDEPEND="${DEPEND}
net-misc/openssh
net-misc/rsync[xattr,acl]
-"
-RDEPEND="${DEPEND}
- qt5? ( dev-python/PyQt5[gui,widgets] )
-"
+ qt5? ( dev-python/PyQt5[gui,widgets] )"
PATCHES=( "${FILESDIR}/${PN}-1.2.1-no-compress-docs-examples.patch" )
src_configure() {
pushd common > /dev/null || die
- ./configure --python3 --no-fuse-group || die
+ # Not autotools
+ ./configure --python3 --no-fuse-group || die
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- ./configure --python3 || die
+ ./configure --python3 || die
popd > /dev/null || die
fi
}
src_compile() {
pushd common > /dev/null || die
- emake
+ emake
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- emake
+ emake
popd > /dev/null || die
fi
}
src_install() {
pushd common > /dev/null || die
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
popd > /dev/null || die
+
if use qt5 ; then
pushd qt > /dev/null || die
- emake DESTDIR="${D}" install
+ emake DESTDIR="${D}" install
popd > /dev/null || die
fi
einstalldocs
+
if use examples ; then
docinto examples
dodoc common/{config-example-local,config-example-ssh}