summaryrefslogtreecommitdiff
path: root/app-arch/tarsync/tarsync-0.2.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tarsync/tarsync-0.2.2.ebuild')
-rw-r--r--app-arch/tarsync/tarsync-0.2.2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/tarsync/tarsync-0.2.2.ebuild b/app-arch/tarsync/tarsync-0.2.2.ebuild
new file mode 100644
index 000000000000..869ab23ff2c4
--- /dev/null
+++ b/app-arch/tarsync/tarsync-0.2.2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://github.com/zmedico/tarsync"
+SRC_URI="https://github.com/zmedico/tarsync/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux"
+
+DEPEND=">=dev-util/diffball-0.7"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin tarsync #make install doesn't support prefix
+ einstalldocs
+}