summaryrefslogtreecommitdiff
path: root/app-arch/tarsync/tarsync-0.2.1-r2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/tarsync/tarsync-0.2.1-r2.ebuild')
-rw-r--r--app-arch/tarsync/tarsync-0.2.1-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/tarsync/tarsync-0.2.1-r2.ebuild b/app-arch/tarsync/tarsync-0.2.1-r2.ebuild
new file mode 100644
index 000000000000..295c7e7cbef1
--- /dev/null
+++ b/app-arch/tarsync/tarsync-0.2.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Delta compression suite for using/generating binary patches"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~amd64-linux"
+
+DEPEND=">=dev-util/diffball-0.7"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-make.patch
+ "${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-symlink.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin tarsync #make install doesn't support prefix
+ einstalldocs
+}