summaryrefslogtreecommitdiff
path: root/app-arch/snappy
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/snappy')
-rw-r--r--app-arch/snappy/Manifest2
-rw-r--r--app-arch/snappy/snappy-1.1.7.ebuild65
2 files changed, 0 insertions, 67 deletions
diff --git a/app-arch/snappy/Manifest b/app-arch/snappy/Manifest
index e0292fd591e7..76296f11c614 100644
--- a/app-arch/snappy/Manifest
+++ b/app-arch/snappy/Manifest
@@ -1,6 +1,4 @@
AUX snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch 970 BLAKE2B 5288f515e3806394b540bd5187cc277467b462526fac35dc2112fde0529f952083a02dc3bdd349e8fd6d24598f1021904861dec683a03bf9c98d9bfc60bb0aa7 SHA512 070e4bb4c2e4f67d6c22743d82660506478fee8c6fd936508a2beb687a57fbb7325283fa2e9b3f6cdac599a5bc19519b35236752d1926554047444322ac7689f
-DIST snappy-1.1.7.tar.gz 1090550 BLAKE2B e389c96e093de5db92b896a7fa17a90d3ad0be07972e279321f24875f0f0c8c704ff478f4902a6356d458f93c249e3e06424d5a4efc9753a23ab12b7ee83a088 SHA512 32046f532606ba545a4e4825c0c66a19be449f2ca2ff760a6fa170a3603731479a7deadb683546e5f8b5033414c50f4a9a29f6d23b7a41f047e566e69eca7caf
DIST snappy-1.1.8.tar.gz 1096137 BLAKE2B e21f2ea23727f118920b7f67981354194f12d1d61eaa18eb1cb2f4285fabafdd221b88cf1e3b3261634f65469a714d3efe6b218c0b1e9d41639cdeb21097d75e SHA512 efe18ff1b3edda1b4b6cefcbc6da8119c05d63afdbf7a784f3490353c74dced76baed7b5f1aa34b99899729192b9d657c33c76de4b507a51553fa8001ae75c1c
-EBUILD snappy-1.1.7.ebuild 1953 BLAKE2B a7573f26da03773394dc43d0098f30cdc04747ea4411fa4b0861f1cb0028211c714e5a977a19fc1ca72e8d01caa725b6a4b6b28c58b0eee9ebb81019c75847c8 SHA512 cd174fe770ad3e669409e9bdf6f79af5c8d86b811d63f0d88743f19666b2ad95cd1b03759b388d932513972eae8cf92ae719b16a91b10078e6084daab8a37ccc
EBUILD snappy-1.1.8.ebuild 1804 BLAKE2B e8e9caaa8e080c6c56eebedfbf11e9d294ecdeda48e42cd24029f10138d5fcce0397f3607de64e176f17eade8a4d3c3a34046ac3c1406c5fcf4385c13b935402 SHA512 fefb29548ce8674cd7d11ceba5768fae44fe4908ca5106205fcda86cde178da3ca174a38693e1f4e63650bb62a5f5fbb28851bfdb2625a45fe969eb61327a0b8
MISC metadata.xml 584 BLAKE2B 9972ee3948809ca45ea18129bde88c5a93fbe73d24c6e125cd13a45bb381099110dc0e006cf76a57d0baf7d18001bf261dd1d6db1025750b114903725e2e3aa4 SHA512 5897170c6fb84f520d879b5df295608b92376150ed2535b578ff04c5cfb5a0ba334a7aee3ad1ef41a8ed45b3fb36425e1dc0e54c0fb880e0c2bf72803a2da552
diff --git a/app-arch/snappy/snappy-1.1.7.ebuild b/app-arch/snappy/snappy-1.1.7.ebuild
deleted file mode 100644
index b72edb15b8f9..000000000000
--- a/app-arch/snappy/snappy-1.1.7.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit cmake-multilib
-
-DESCRIPTION="A high-speed compression/decompression library by Google"
-HOMEPAGE="https://github.com/google/snappy"
-SRC_URI="https://github.com/google/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV%%.*}"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 s390 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
-RESTRICT="!test? ( test )"
-# upstream killed static lib support with build system update
-# (and we have packages depending on the flag)
-REQUIRED_USE="!static-libs"
-
-# all test dependencies are optional:
-# - gflags-2.2 is supposedly needed for command-line option parsing
-# but it's a huge hack and does not work,
-# - gtest probably gives nicer output,
-# - compression libraries are used for benchmarks which we do not run.
-DEPEND="test? ( dev-cpp/gtest )"
-
-# AUTHORS is useless, ChangeLog is stale
-DOCS=( format_description.txt framing_format.txt NEWS README.md )
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}"/snappy-1.1.7-0001-cmake-Add-missing-linking-to-GTEST_LIBRARIES.patch
- )
-
- # command-line option parsing does not work at all, so just force
- # it off
- sed -i -e '/run_microbenchmarks/s:true:false:' snappy-test.cc || die
-
- cmake-utils_src_prepare
-}
-
-multilib_src_configure() {
- # TODO: would be nice to make unittest build conditional
- # but it is not a priority right now
- local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-
- # use gtest for tests only
- -DCMAKE_DISABLE_FIND_PACKAGE_GTest=$(usex '!test')
- # gflags does not work anyway
- -DCMAKE_DISABLE_FIND_PACKAGE_Gflags=ON
-
- # we do not want to run benchmarks, and those are only used
- # for benchmarks
- -DHAVE_LIBZ=NO
- -DHAVE_LIBLZO2=NO
- )
- cmake-utils_src_configure
-}
-
-multilib_src_test() {
- # run tests directly to get verbose output
- cd "${S}" || die
- "${BUILD_DIR}"/snappy_unittest || die
-}