summaryrefslogtreecommitdiff
path: root/app-arch/rpm/files/rpm-4.20.1-no-hardened.patch
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/rpm/files/rpm-4.20.1-no-hardened.patch')
-rw-r--r--app-arch/rpm/files/rpm-4.20.1-no-hardened.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/app-arch/rpm/files/rpm-4.20.1-no-hardened.patch b/app-arch/rpm/files/rpm-4.20.1-no-hardened.patch
new file mode 100644
index 000000000000..ea5135c1dccd
--- /dev/null
+++ b/app-arch/rpm/files/rpm-4.20.1-no-hardened.patch
@@ -0,0 +1,12 @@
+Don't override Gentoo's default _FORTIFY_SOURCE.
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -426,7 +426,7 @@ if (ENABLE_ASAN OR ENABLE_UBSAN)
+ endif()
+
+ # try to ensure some compiler sanity and hardening options where supported
+-foreach (flag -fno-strict-overflow -fno-delete-null-pointer-checks -fhardened)
++foreach (flag -fno-strict-overflow -fno-delete-null-pointer-checks)
+ check_c_compiler_flag(${flag} found)
+ if (found)
+ add_compile_options(${flag})