summaryrefslogtreecommitdiff
path: root/app-arch/ncompress
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/ncompress')
-rw-r--r--app-arch/ncompress/Manifest1
-rw-r--r--app-arch/ncompress/ncompress-5.0-r1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/ncompress/Manifest b/app-arch/ncompress/Manifest
index 0a4117ce6f60..95b65eb89b6f 100644
--- a/app-arch/ncompress/Manifest
+++ b/app-arch/ncompress/Manifest
@@ -1,3 +1,4 @@
DIST ncompress-5.0.tar.gz 34185 BLAKE2B 7b296bd00024bfb483d3261ff8aa6e47a6be8c62b445c3d456d702b69fbc2a7b731326f7ea91aa331ba8e8a27936f4318b3e252cc978b6bf3198e8812988913f SHA512 5bc886f98f25b03d034e8d8ebb0ee9388d727ee3e0c6d8a906698b2f8fa5c930f55d857486244b7f40447c7b74f3c620626600db619d0c6d6fd434f52912be42
+EBUILD ncompress-5.0-r1.ebuild 1087 BLAKE2B 7a5642bc0a7d3ccb69b2b38351ba6c0f4fe316523961151d0139ebaa82314d800f4b9dab32b919d3c8fce4f9fd40faa2df310a11b9d95583fa2bc36f8092951d SHA512 c09fab1b495a965c9daffa00a8f299af979c6e351c9234561c0fe61d0c88c34338a70bbc9df7971415ca8aed0a4157e9901a7efce84ea9dcd2044a7daed43084
EBUILD ncompress-5.0.ebuild 763 BLAKE2B a5eac829aab31ff186a7668542410587ed8bb8fd8787bd2b3053003e9a3a72515dec842050a6bfdadc2115bfffd05e15b7a71a8cd79fc40a3a87cb4391f26416 SHA512 a2753555531e73a519331c9b282e1cd54781093649eec68209bd4c0cbc1e78009f90b9b4a9c0c36ff79afa6b05451084e9a51b00a002ace40cec8fbf138097f5
MISC metadata.xml 393 BLAKE2B 24133518bbc568fc7861bb255fcd6ebb34d8ed24912889ac7df4f0517f34fcb281a3eff0c75d5a285891f820956b680270b42cdb1f5cf7a417f43241b46d392f SHA512 7b5f6f0ea16f60fb9b05d9a27701b56e80b62c8e9d1fbf05ecc75015f51dc010f53546661013ec36831051985360e21fb374bc8b5006ecc14f707f9b715fe745
diff --git a/app-arch/ncompress/ncompress-5.0-r1.ebuild b/app-arch/ncompress/ncompress-5.0-r1.ebuild
new file mode 100644
index 000000000000..2b3cfe61914e
--- /dev/null
+++ b/app-arch/ncompress/ncompress-5.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Classic compress & uncompress programs for .Z (LZW) files"
+HOMEPAGE="https://vapier.github.io/ncompress/"
+SRC_URI="https://github.com/vapier/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+src_prepare() {
+ default
+ # First sed expression replaces hardlinking with
+ # symlinking. Second sed expression fixes the symlink target
+ # to use relative path to a file in the same directory as the
+ # symlink (so point to compress instead of
+ # $(DESTDIR)$(BINDIR)/compress).
+ sed -i \
+ -e 's:\bln :ln -s :' \
+ -e 's:\(\bln [^$]*\)\$(DESTDIR)\$(BINDIR)/:\1:' \
+ Makefile.def || die
+}
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ emake install_core DESTDIR="${ED}" PREFIX="/usr"
+ dodoc Acknowleds Changes LZW.INFO README.md
+}